Game Update 1.15 - July 19th, 2021

Chris, I’m having gradient issues with a Kickr Core., especially on Makuri Island!

1 Like

This rendering bug is still present from 1.14.x:

1 Like

After updating last night I had my worst Zwift experience ever. Did a 10 minute free ride warm up then joined a scheduled Roval ride. After about an hour and ten minutes I started getting constant disconnects of my trainer(power), heart rate, and or cadence. Usually it was just two of the three. The drop out outs lasted long enough that my avatar/progress ground to a halt. It was so frustrating that I gave up after 10 minutes of this. The rides did save. Very hesitant to waste my time on Zwift again until issues are fixes. Platform:

Windows with latest app version
iOS companion app latest version
Kickr Snap v2 with latest firmware
Wahoo cadence sensor
Garmin Forerunner 945 broadcasting heartrate


Same ATV issue here.

Doesn’t work for me .using iPad stages power meter and direto x

This upside down wattage issue still isn’t fixed in the July update (ATV 4K)

Apple TV

Same issue I have had since the update I’m fairly reliant on being able to exercise when I have a spare moment due to young family I hope they fix this ASAP

Same thing happening for me and my partner, for all workouts with multiple efforts, over different days. I’ve got a galaxy S10 and partner has some Apple thing :man_shrugging:t2:

The actual power sent to the trainer and displayed in the middle is correct; just the list of efforts on the left is duplicated.

the loaded workouts seem to be having an error for me post upddate. but also the post activity workout files. for ref, did an 18.2km race ( 3R Innsbruckring Flat Race - 2 Laps (17.6km/10.9m 154m)), and in activity data all correct, come the end of the race, shows everything on screen correctly, however when i end the ride, the uploaded activity file is beyond incorrect, showing wrong distance, speed, power, map. I assume its linked to the app update, but not sure when it will be patched. Bit annoying to have to manually input everything post ride… running in ipad, latest app version…

A post was merged into an existing topic: Can’t pair both Controllable and Power signals separately [1.15.0] [July 2021]

Unfortunately whatever has been done makes cycling a bit nauseous moving all over the road often veering over to the right head on into oncoming cyclists.

1 Like

Yesterday my FIT file was corrupted when saving after doing a warmup then automatically joining an event; warmup saved properly the event FIT file was corrupted with some correct data and some from the warmup file…

Did a 1.6km warmup followed by joining an event and doing 105km. FIT file only shows the 1.6km warmup. On the Apple TV

Any feed back on this, I had the same problem.
I checked the battery several times on the stages. Made sure my Stages actual worked by using a Garmin watch and cycle computer at the same time meaning ant+ and Blue tooth were working, checked with the stages app that power meter was working. Some time later I decided to find my old cadence sensor put a battery in it made sure it was working fit and pair, this work around plan worked but I’d missed a meet up then missed an event then hardly anytime left to do anything worthwhile…

My issue is this, Zwift could’ve put a message up on the App upon start-up of the app at point of use, this would’ve mitigated most of the inconvenience and time messing about that would seem now to be for nothing and no fault of my own… Wasn’t happy at all…

Communication needs to better…!

Me too … iPad, stages power meter and Kickr snap candence not found when searched if the power source is the Kickr.

If I choose power source as the stages then it will find the stages in the cadence search…

Poor that Zwift don’t put a message up on the app at start to mentioned the issue, messed about for hours thinking it was the Stages…

Communication needs to be better

1 Like

How do you roll back the firmware? I tried on the Wahoo iPhone app, but could not figure it out.

Hi Rob,

When you connect to the wahoo kickr from your phone app you will see the icon in the image circled. Tap it about 10 times and an extra drop down appears with the firmware. If you click that it gives you a list. I rolled back to 4.1.2 and it seems to work well. I found this info in a forum and tried it as a last ditch effort and it worked.

Thanks. I rolled it back and it did not help. The final thing I tried seemed to work. I switched the sensor reading from my iPhone to the PC in the pairing settings screen.

I just tried to get onto Zwift. It forced me to do the update. Every time I now try to run Zwift it just exits and doesn’t run the game. I guess the app is crashing. It has been fine on this tablet up to now. I only use the tablet for zwift. Nothing else has been installed on it. BUSH SPIRA B3 10 Tablet - Android v 7.0 - Kernel version 3.18.35. Can supply more detailed info if required.