FPS Capped at 30 with High Powered PC

Hi All,

I’ve recently started using my gaming pc to run Zwift and I was curious to see what kind of FPS I was getting on the Ultra settings. I uploaded a recent Tour de Zwift stage ride into Zwiftalizer and noticed that my FPS was capped at a steady 30FPS for the entire ride? Anyone know why this may be happening? Are the large group rides capped at a certain frame rate? I’m running my game in windowed mode to a 4k Samsung TV via HDMI.

Thanks for the help!

Here is another ride for reference. A warm up in a non-crowded ride:

In a big group event you are CPU bound, which causes the frame rate to drop below your target (presumably 60fps). To avoid it dropping all the way to 30fps and sometimes being stuck there, enable triple buffering in the Nvidia Control Panel.

That being said, if it’s the same when it’s not busy then the chances are your HDMI cable, port on the TV, or both are not capable of 4K60 input. You need a Premium High Speed 2.0 cable (Amazon Basics is fine) and ensure you’re using a capable port.

Edit: just noticed you’re using Windowed mode. Make sure Windows is set to 60Hz refresh rate and not 30Hz.

Thanks for the help Dave! Looks like my default refresh rate while connected to the TV was set to 30hz. I changed the refresh rate in the Nvidia Control Panel to 60hz and that seems to have done the trick.

Tested during a “Just Watch” in Watopia near the busy start point:

1 Like

Good stuff. You should still enable triple buffering though. :wink: Capping at 61fps is useful too, to prevent the annoying rubber band/zooming effect.

Just enabled the triple buffering :+1: Did another test and it looks like I’m getting that rubber band/zooming effect. How can I cap the FPS to prevent it?

Same place, in the Nvidia control panel. Set the max frame rate to 61fps. That figure is the best compromise.