Frame Rate ThinkPad X1 Extreme Gen 4 with RTX 3050

I just received my new ThinkPad X1 Extreme Gen 4. It has an i7-11850H, 32 GB mem, SSD, and an Nvidia RTX 3050 (4 GB). Whatever resolution I pick, I am only getting 30 FPS (from Zwift Analyser). Always 30, not less, not more. This tells me that somewhere something is limiting Zwift’s display output.

Does anyone have any clues ? I had a ThinkPad P1 Gen 5 (which I returned) which always showed 60 which I believe to be the max refresh rate of laptop displays. But here I have 30…


Ensure the refresh rate in Windows is set to 60Hz, and enable triple buffering in the Nvidia control panel. You have a 60Hz display so 60fps should be possible when not limited by your GPU (you should be running Zwift on 1440p) or CPU (busy events/Pace Partners).

PS: I really hope you didn’t buy that just for Zwift, or even with Zwift in mind. :wink:


Well, I went into the Nvidia Control Panel and enabled Triple Buffering and no change. The odd thing of this laptop is if I right-click the desktop and go to Display Settings (Windows 10 btw), and go to Advanced Display Settings, the system shows a Refresh Rate of 59.999. There is no other option. I looked everywhere to change it to 60 but no go.

P.S. No I bought the TP because I run heavy virtual machines on VMware Workstation.

Have you made any other changes to the Nvidia settings? Set it back to default if so, you only need to enable triple buffering from there. Check the refresh rate is on 60Hz in the control panel too, and that it’s set to the native resolution (progressive). You need to do this with Zwift closed by the way, it won’t work in real time. Also, are you using windowed mode?

Otherwise, post your Zwiftalizer link.

I reset all the Nvidia parameters to default, rebooted, still the same but then changed Zwift to Full Screen Mode. Now, I am getting 60 FPS (or close).

How do I post the Zwiftalizer link ? The forum won’t allow it…

Thank you for the awesome assistance…

Full screen mode uses your display’s native refresh rate (60Hz = 60fps), windowed mode defers vsync control to Windows. So it’s still an issue with your refresh rate setup in Windows itself somehow. Just post the letters after the .com and I should be able to see it.

Here ya go. This is the portion after the /public



Is this from before or after setting full screen mode and enabling triple buffering?

I probably wouldn’t recommend 4K on that GPU, to be honest. 1440p will give you much more consistent frame rate performance.

1 Like

I had reset all the Nvidia parms to default (so no triple buffering) but went to Full Screen Mode. I have done another test now in 1440p. Yes, very close to 60 all the time. Here is the link


You should still enable triple buffering, it prevents the frame rate dropping all the way to 30fps when either your CPU or GPU is struggling to keep up. Keep everything else as default.

1 Like

Have a look here in the Nvidia control panel.

I turned on Triple Buffering. The option you show in the photo does not appear in my Nvidia Control Panel.

But it does show a 60 Hz refresh rate. I don’t know why stupid Windows can’t show the proper value…

Laptops… :nauseated_face:

Anyway if it works fine in full screen mode and you’re okay with that then don’t worry about it. Definitely a config issue though, somewhere.