FIXED: Kurt Kinetic Trainer receiving 'No Signal' when pairing with Android Zwift Companion

cant-pair
trainer
(Kirsten Walter) #83

Unfortunately it still isn’t working for me. I tried uninstalling and re-installing kinetic fit and zwift companion. It still can’t find the device (not even getting to the “no signal” stage).

Kinetic fit connects, and tracks kph, cadence, power on the phone app…

Any advice?
Thanks.

0 Likes

(Aaron) #84

Kirsten,
Make sure the companion app is connected to Zwift over wifi by looking for the app background to turn blue. When pairing to the Zwift companion app, make sure that the kinetic fit app and any other app that might pair to the kinetic is force stopped (not just closed) on your phone. Unplug the kinetic for about 30 seconds then plug it back in. Open up your bluetooth settings app and look to make sure that the kinetic shows up as an available device. It might only show up by its mac address rather than by the kinetic name. If you have successfully done all that and it still isn’t being discovered, then it may be something else interfering with the bluetooth signal.

0 Likes

(Kirsten Walter) #85

Thank you so much. It finally worked! Hooray!
Kirsten

0 Likes

(Aaron) #86

Ride on!

0 Likes

(Alicia Gravel) #87

Hi! I bought my Kinetic Smart trainer a week ago to train with my friends on Zwift and thought it was my trainer who was the problem 🤦

Yesterday I was able to connect but had the “no signals” for 45 minutes! I restarted my laptop twice, my phone once… (PC and Android Pixel 2).

I’ll try later today.

0 Likes

(Aaron) #88

Hey @Alicia_Gravel, make sure you have the update that came out on Dec 3, as it seems to have resolved issues for quite a few people. Also, if pairing your Kinetic through the companion app take a look at the checklist of things to try that I posted above as it seems to have helped Kirsten to get connected. If that doesn’t help, try to describe in excruciating detail the steps you are taking to pair your Kinetic.

0 Likes

(Nicolas Pierson) #89

hi
it’s nice for me !

Good job, thanks !

Le lun. 3 déc. 2018 à 22:07, Vincent W. gozwift@discoursemail.com a écrit :

0 Likes

(Alicia Gravel) #90

I tought my Kinetic should run in the background! Thanks so much! Everything works like a charm now :smiley:

1 Like

(D.) #91

Thanks for your help, returned my Kinetic Rock and Roll T-6500. I went with a 2018 Edition Kickr Smart Trainer, and it connected as soon as I opened the app on the Apple TV.

0 Likes

(Bruce Forman) #92

Setup: Kurt Kinetic Rock n Roll trainer with inRide module v2 connects to Zwift via Bluetooth and Zwift companion app running on Huwawei Mediapad T3 10 tablet running android v7.

Problem: I’ve never had any problem with dropouts in Zwift just riding or racing. I enter Zwift prior to the Tour de Zwift event and ride around for 10 minutes to warm up with no problems. However, as soon as I enter the TdZ event the power drops out and the pairing screen says “Connected - No Signal”. Nothing I do allows me to pair up again so I switch to ZPower using my Ant+ speed sensor.

I have had the identical problem in both stages of the TdZ that I have enetred so far. It’s got to be a function of the number of riders in the event hasn’t it? Over 2000 in each stage I have ridden.

1 Like

(Ken) #93

I have been trying to figure this out on a brand new unit also and am close to sending back the Kinetic Trainer as a result. This appears to be a problem with the Kinetic proprietary Bluetooth communication protocol they are using that is not reliable. Even their own app they have is dropping the signal, so it may be time to switch horses. If anyone has worked out a method to get their Trainer to connect to a PC or Zwift on Android please let me know.

0 Likes

(Pat Johnson) #94

Mine is working fine now. Try running the kinetic fit app and make sure you have the latest version downloaded to the trainer. The calibration value should be between 7 and 8. Kinetic told me the Bluetooth issue a month ago was not something they could remedy. Zwift fixed it with a version update. Good luck.

0 Likes

(D.) #95

I had the same issue with the Bluetooth dropping signal, even on the app, I’ve used an iPad and iPhone device. I’ve had the latest firmware and software. Sadly, I had to move on from Kurt Kinetic.

0 Likes