First ride on 1.0.2792


(Paul Joyce) #1

Zwift is getting better very quickly, but I did run into a few problems on the new version tonight.

Zwift Launcher crashed during the update. I closed it manually, restarted and it worked.

Zwift Launcher does not seem to exit on its own. I have to close it manually after a ride.
My rider started once on the wrong side of the road.

Biggest problem was that Zwift lost control of the Kickr. I had the Kickr selected in power, and it displayed power correctly, but resistance did not change during the lap – I was cranking along around 200 watts up and downhill at the same cadence.
I hit “A” to be sure the Kickr was selected. It was.

I close Zwift, unplugged the Kickr, re-plugged the Kickr, restarted Zwift, and checked that the Kickr was selected. No luck.

I rebooted the computer, unplugged the Kickr for several minutes. On reboot, I deleted every Zwift .xml configuration file I could fine. Started Zwift, configured from the beginning and all was well again.

I have a theory that because I did the spindown calibration on the Kickr using Wahoo Utility and Bluetooth, that the Kickr was under Bluetooth control when I started Zwift the first time and Zwift only recognized power data, not the ability to control resistance. It works just as normal now.

I’m using a Lenovo Lenovo multimedia remote n5902 – it is much easier than using a keyboard and mouse on the trainer. But, it has no function keys, so I cannot access any of the sounds or gestures while riding.

View 3 was a little flaky. My rider did not have a shadow in view 3 – looked like the shadow of a bike on top of a car. The shadow was there in other views.
My rider veered way off course in View 3, going through boulders and buildings. Incidentally, there are trees growing inside the buildings…

Otherwise, all good. Was able to ride with another human for a while, although it seemed like we both overshot each other trying to draft.
Otherwise, really good and a fun ride.


(Eric C. (Zwift HQ)) #2

Hi Paul,

I tried to test the spindown issue and got it to reproduce on one machine, but not another. In fact, while one machine was failing to detect the KICKR, the other machine in our office picked it up just fine.

It’s very bizarre. With a reboot, everything worked as expected. I tried the exact same test (run spindown via Bluetooth, try to connect with a machine) with another, separate computer and it found it immediately. Even after removing both XML files.

I’ll pass that aspect up just because it’s an interesting occurrence and perhaps they can keep an eye out for something.

We’re working on several of the other issues (as they’ve been reported) as well. Thanks for this excellent feedback, however!


(Paul Joyce) #3

You bet, Eric

Happy to help any way I can. It’s a privilege to be part of the beta


(Eric C. (Zwift HQ)) #4

Hey Paul,

So got some word about this: apparently the ANT+ driver can sometimes just stop responding. Unplugging and then re-plugging the ANT+ dongle can often reset this. Perhaps you encountered this?

According to Jon, the KICKR transmits Bluetooth and ANT+ at the same time. We’ll continue to keep an eye on out, however!


(Paul Joyce) #5

Thanks Chris

Maybe. Power was still being reported, but there was no control of Kickr resistance by Zwift.

It did happen again – I’ve opened a case with all the .fit, .xml and log files submitted.

Thanks!