Firewall Issues TCP/ UDP Netgear Nighthawk

Hello all - I am having connection issues with the Zwift Companion (ZC) app, in that it sporadically connects/ drops intermittently during use and I can’t seem to reliably use/pair.

Current Setup :
iPhone 12 Pro Max, IOS 15, latest version of the app
Apple TV 4k

Netgear Nighthawk MR/MS60 Mesh Wifi with TPLink Modem

I understand looking through the forums that I need to do the following with the ports -

Your router firewall needs to allow all incoming/outgoing Zwift TCP traffic on ports 80 and 443 and all Zwift incoming UDP traffic on port 3022.

My question and where I am getting stuck is that I cannot find anywhere how to do this. I’ve got to this screen in the advanced settings for the Nighthawk router but then have no idea what IP address to use?

Also should I do 3 separate entries for 80,443 and 3022?
I’ve attached a screenshot of the options, thank you in advance for any help!

The Zwift Companion App connects to the Zwift App over your local network. What you are looking at is the incoming WAN traffic.

Turn off WIFI Assist on your iPhone and see if that helps.

1 Like

Thank you Paul, am trying that and a modem reboot again to see if any improvements

You need to make sure that the iPhone running ZCA is connected to the Nighthawk’s wireless and not just using mobile data.

1 Like

So tried rebooting, and switching off mobile data on my phone but sadly same issue persists. ZC opens, sporadically connects and pairs but freezes without getting the live data, drops and then goes back to the menu.

Tried closing / reopening the app on a few occasions and still no joy.

Is there anything else I can do to fix this?

Try splitting the WiFi signals into 2 different SSID’s one for 5Ghz and the other for 2.4Ghz.

How is your Zwift device connected to your router? If it using wireless, after splitting the 2 signals into 2 different SSID’s make sure they are connected to the same one.

I use a Netgear Nighthawk and I have had no issues with the ZCA.

I connect my Zwift computer using a wired connection and the ZCA connects to the ZA without any issues.

You could have some interference that is causing you issues.

I have found that I had to give my PC and Phone static IP addresses to see each other on Zwift. Strangely my wife has a similar setup and I did not had to do it for her.

But it is worth trying.

So slightly odd, but splitting the SSIDs didn’t fix it… but… creating a new ‘guest network’ within our home network just for zwift and ZCA seems to have somehow fixed it?!