Connection disconnects/failure, UDP connection timeouts

Hi all,

New Zwifter here…enjoying so far.

Zwift has been working flawlessly since December (first install) on AppleTV. However, last week, I came back to a ride I had paused a couple of days before (I don’t normally do this), and there were “connection disconnect” and “connection failure” banner messages. Ever since then, every time I load a course for a ride, other riders appear briefly, then disappear with the “connection disconnected” message. Sometimes other riders reappear, sometimes not.

I have connected my computer running the Zwift app directly to the modem (fiber), bypassing the router, but this doesn’t work. However, if I connect wirelessly through my air card (cellular), everything works, so it’s definitely my network or ISP. Further, there are a ton of UDP connection timeouts in the log.

Zwift is the only thing on my network that has issues, and I have fast speeds (1G fiber), so it’s not that. Does anyone know what I should ask my ISP or Zwift support for to get this resolved? Should I throttle the speed down to see if that works (I get about 910Mbps)?

Thanks in advance for any help!


It is probably your firewall that does not recognize the incoming UDP traffic as associated with Zwift and starts blocking it, especially when there is too much of it going on (which correlates with the number of cyclists around you). You need to check your firewall log (which would be easier to do if you were running firewall and zwift on your PC) to confirm that it is indeed what is happening and open it for UDP traffic from ports from Zwift servers send it. Your wireless router also has a firewall, most of them do. Check that one as well. I saw this issue with firewall on my computer and opening the ports, per instructions on Zwift web site, helped. Recently something changed: even with configuration set correctly (as it worked in the past), I have to turn off firewall during massive events (Tour de Zwift) to prevent loss of UDP traffic. I found that if firewall is on and loss of traffic happened (which almost unavoidable during Tour de Zwift events), turning it off fixes the problem immediately. I did not have time to research it further yet to understand what needs to be changed in the firewall configuration to help it not lose track that it is a legit traffic.

If you use VPN, that thing can have a firewall on their end, too, which may cause problems.

Have you tried restarting your modem and router?

  • As for the AppleTV, has it been updated to the latest version of tvOS:
    15.3 (build 19K547) January 26, 2022

  • Is Zwift updated to the latest version:
    v1.21.2 (build 1.0.100353) January 21 2022

Hi Andrei,

Thank you for the suggestions. I did try bypassing my router and connecting directly to the fiber modem so that I could bypass the router firewall. I also disabled the laptop firewall as well. However, I am going to open those ports as you suggest,

Interestingly, over the last couple of days, Zwift is working again. I don’t know whether or not Zwift has changed anything, but I notice that my ISP has throttled down my speed from about 910Mbps to 90Mbps. I’m noticing at the slower speed, Zwift works perfectly. I’m not sure if this is the solution, but I will be watching it over the next few days and report back. By the way, the router and pc firewall are back on, and I have not messed with the ports yet. If my ISP bumps the speed back up again, I think I’m going to add a bandwidth limiter to my router to fix the problem (assuming this comes up again).

Hi Lin,

I did update everything - thanks for the reminder. We often skip the easy stuff, thinking it must be something complicated.