Extremely short battery life of Zwift RunPod

Is anyone else experiencing terrible battery life and needs to constantly change their RunPod’s battery? Any solves?

I’ve owned my RunPod for about 1-2 years, and lately it’s had horrible battery life. I’ve only run a handful of times this season, but I’m already on battery #4. Half of the time I go to run, my RunPod will connect, but the battery indicator is red, and my avatar won’t move. Replacing the battery does the trick. In between runs, my pod is sitting idle on my shoes, which are not used for anything except zwift treadmill runs.

I do recall having a similar issue when I first got the pod, but after a milestone firmware update, the issue was rectified. Now back to same thing. :frowning:

First question is if you are on the latest version of Zwift?

I seem to recall there were some cases reported about a year ago where users would see the red light and avatar would not move and resetting the RunPod (by removing and replacing the battery) would solve the issue. Zwift released a fix for this issue so that it would not be necessary to reset the RunPod to fix this issue. You should not be having this issue with the latest version of Zwift (or else maybe the issue has returned somehow).

As a test, next time this happens, you could try replacing the battery with (and I know this sounds weird) the exact same battery you just removed. Because this was the workaround for the previous old issue. Removing and replacing the battery effectively resets the RunPod if it has been placed into a weird state. If removing and replacing with the same battery still does not work, then it sounds like the issue is really about battery drainage.

You say the RunPod has been idle on your shoes, but are the shoes idle?

After re-reading your message, I get the idea that you only wear the shoes for running, but is there anything in the environment that could cause vibration or movement to the shoes. You can test for yourself that a small tap on the RunPod will wake it up. So, and I know this is not the case, but if the shoes were on a washing machine, the vibration would continually wake up the RunPod. Again, I know that is not the case, but it may be worthwhile to see if there could be any vibration or movement around the RunPod that is causing it to activate when you are not actually running on the treadmill.

Hi Catherine - I have recently had the same issues as you, every 2nd run the batteries die​:rage:! My husband’s runpod bought at the same time has not had this issue (used at the same time as mine and same brand of batteries). I have done some research and now bought different batteries (Duracell) - so let’s see how these go. There are no vibrations, nothing waking it up, no active connections unless I am running so bemused as to why my batteries are dying so quickly. All firmware is up to date as far as Zwift allows us to tell . It would be useful if Zwift could include some way of seeing the battery level from Zwift or the Companion App. Incidentally out of the blue, a couple of days ago, my husband said he did receive a ‘battery low’ email from Zwift…I have never received one :thinking:.

1 Like

@Catherine_Lee and and @Dobby_Gee
Please also update your Zwift app to the latest version. If you’re using iOS / Android / Apple TV please make sure that those operating systems are set to allow your apps to auto-update.

If you continue to see this issue after trying the things Mike suggested, we’d like to see the log files from the computer running Zwift. Here’s how to locate your log files and send them in. When you email them to us, please reference this forum thread’s URL.

Hi Shooj - thanks for your suggestion. However (as sad as it sounds) I check every morning and also just before every event to ensure that my Zwift/Companion Applications are up to date which it always is. Just a question though, if you wouldn’t mind answering for me - is this (runpod battery drain problem) a previously known issue that has already been fixed by an App revision. As I said my husband has a runpod which was purchased at the same time, with same brand batteries as mine, used (we run together) and updated with the same firmware but he doesn’t suffer the same issues. In short, what I am asking, is there a faulty batch of runpods?


At one time, similar symptoms were resolved with a game app update followed by a reset of the hardware by removing / reinserting the battery. Please try that, and if you still see the symptoms, we’d like to see if the log files give us any insight.


No, except that I remove the battery between infrequent usage. It seems to drain the battery while not in active use. That may have nothing to do with Zwift. My device predates Zwift’s acquisition of the technology.

Thanks, everyone, for your suggestions.

  1. I do constantly update the Zwift app, so am generally current
  2. Shoes sit idle on treadmill between runs - I don’t think they’re ‘vibrated’ in any way, but that’s an interesting thought. There does seem to be a slow battery drain over time…
  3. I actually did try removing the ‘dead’ battery and re-inserting it (and also an older one that died in the same way) – no luck. It does seem to be a dead battery issue rather than buggy behavior, though I may test it out some more.

Now that my battery in my shoe is fresh (as of 1/6), I’ll pay a little more attention to how it drains and will again try some of the suggestions. If the same thing happens, I’d be happy to send in log files.

Thanks all!

1 Like

My experience is that the runpods eventually fall apart even if you replace the batteries. They’re not built to last.

I owned two before Zwift purchased the company. Both eventually started requiring battery changes every few months (or I was constantly unscrewing and screwing in the battery door), and then they started to report every other step or simply shut off in the middle of a run.

Heya! Back again. :slight_smile: After replacing my battery and running for less than 2 weeks with it, it’s again dead. I ran roughly 15-20 miles total on the battery.

When I went to run today, I couldn’t pair with the pod even thought it flashed a green light after I tapped on it, indicated that there was a little juice left. As recommended, I took the battery out, put it back in. Finally got it to pair, but avatar would not move - I couldn’t calibrate, either. Repeated a couple of times, sometimes restarting Zwift. Finally replace battery, worked like a charm.

I can send you the log files now, but I can’t get them off of my iPad that I use to run the Zwift app. I get to the screen that shows log files, I select them (or one or a few… I’ve tried this many times), click OK, then nothing… it just takes me back to the main Zwift screen, and no emails have materialized with log files. Any suggestions?

Hi Catherine - just saw your query. I just tested what you did on my iPad and it does work…immediately after pressing OK, a new email window opens up with the files already attached so the files can be sent. So it should work and sounds like you are doing the right thing. One thing I would suggest though, if not done for a while is to do a full restart of your iPad as it can often help resolve some issues.

Figured out the issue. My email was no longer configured so once I set that up (again, not sure when it was wiped) I got the log files. Am going to send in what I have…

1 Like

Have the same issue. Relatively new Zwift Pod. Updated apps, new battery more or less every time used. My theory is an error in the pod preventing it from going to sleep. Cannot possibly see any other root cause :frowning:


Continuing the discussion from [Extremely short battery life of Zwift RunPod]

I am having the same issue. All apps are current and I am using my apple watch to get my heart rate to Zwift. I ran one 5K and when I went back to run the battery was dead. I have put in a new battery. I did notice something strange. Even when I ended the run and saved and exited and closed the app on my phone. I noticed the watch was still synced to the heart rate. The only way I could get it to stop was to shut my apple watch off and restart. I have been storing my shoes upstairs in our exercise room. We have a treadmill about 16 feet from my shoes and my wife runs. What are your thoughts?

1 Like

That’s my best guess, too, Martin. I sent in log files not quite 2 weeks ago, but I haven’t heard anything yet. It might help if more of us send in log files and create tickets.

Adding to this discussion. I purchased one around Jan 1st and have been through 3 batteries already. Total of 5 hours of run time. The shoes just sit on the treadmill in between uses. I guess I am encouraged that I am not the only one…
I have started removing the battery in between uses so I don’t go broke. Unfortunately, that is a total drag.
Hopefully this gets resolved.

I know it doesn’t help, but to show this isn’t an issue experienced by all, I haven’t replaced my battery in the last 8 months! I use Energizer batteries.

I am having the exact same issue = new battery is required after every 2 runs… must not be going to sleep properly. are there any firmware updates avaialble for this or shall I just send my logs in too? Thanks!

I have the same issue. I’m on my second battery in a month. It’s really absurd. They clearly stay awake and drain while not in use.

1 Like

Same issue here. It doesn’t matter what kind of battery brand I use. I experience this issue the last few months…