ERG Workout delay - Elite Drivo II / ANT+ / PC


I’ve been trying to do some workouts in the last couple days using ERG mode but I have been experiencing some issues. I’m using a Drivo II trainer with Zwift PC (last version) connected through ANT+, although I’ve tried changing it to using Bluetooth/ Swift Companion the problems where the same and even more accentuated.

  1. The resistance arrives quite late, maybe 30 seconds later and that’s super annoying when doing intervals. Using other apps this does not happen but only with Zwift.

  2. If doing a long interval, where the delay does not matter that much, if I keep the suggested cadence as steady as possible, the power seems to be down continuously by 15 watts which makes it as annoying as the previous issue.

Tried taking a look at the settings to see if there’s any way to adjust this but seems it’s not possible.
The “Trainer Difficulty” setting has no effect when on workouts even set at MAX.

Any suggestions on what might be causing this issue?

I’ve owned an Elite Direto for almost a year now, and I too suffer from the ERG delay in workouts, which effects short interval sprints. I either have to anticipate and ramp up early, or just do my best and fail the interval.

On the old Zwift support site there was a thread about this, and people mentioned that it was an Elite issue, not Zwift, as Zwift just sends the required power requirement to the trainer, but the trainer is doing some power smoothing and hence the delay reaching this power requirement. Search the Elite forums where some have suggested changing the smoothing value from the Elite app. I haven’t tried it, as I free ride most of the time.


Thanks Steven, I took a look at Elite forum and seems other people are having the same issue.

1 Like

Aside from checking on the Elite side, we do have an ANT + troubleshooting guide as well:

I have the exact same issue using and testing the Elite Drivo 2. When in ERG mode the trainer is not working quite well. I have some video’s available to show the issues.

1 Like

Bastiaan, you should check this thread in Elite forum:
seems a well known issue which Elite is playing dumb. Also some people complaining about the same in TR forum.
I’ve done several tests, even with Elite’s own software and the only issue is with ERG.
For example, using Zwift, the gradient change is immediate while free riding. Same thing using the myEtraining app and manually setting a power, if you change from 100W to 300W it takes 2 seconds, when doing workouts in ERG it takes on avg. 12sec. I did a test requested by Elite where it’s clearly visible the delay.
It’s the way the Drivo II is programmed in ERG, at this point I’m not expecting much from Elite. They’ve been promising firmware upgrades for the Drivo I since more than a year, people are still waiting, so I seriously doubt it will be solved anytime soon. Best solution, sell it to a bad friend and get a Wahoo. Tried a Kickr core with my same equipment, same location and in ERG it was spotless.
Also, just to make sure it wasn’t an ANT+ connectivity issue, I’ve checked the logs in Zwiftalizer and the connection was always perfect, so it’s not a problem of interference but just terrible programming skills from Elite.

1 Like

Thanks Patricio, read the topic yesterday and saw the same troubles.

I am testing and reviewing the unit for a cyclingblog. Wanted to know if others had issues as well. Got that answered pretty quickly :wink:

1 Like

@Bastiaan_Gaillard @Pato thanks for posting this up. I’ve just been using an Elite Drivo II for a week - brand new - and bought it because of the advertised fast response time / fast to change power, described as 3x faster than before.

My experience on the first few rides … it takes around 12s (12 seconds) for ERG to ramp up to the power that the application has sent.

Drivo II is supposed to be really fast at this and it is incredibly slow. It makes ERG pointless. And we pay £1,000+ for a trainer that seems unable to do what it says it can.

I’m aware some workaround suggestions suggest using a small chainring at all times. I think that can help a little.
My issue is this - other trainers don’t do this - other trainers are pretty quick. in fact other trainers are plenty quick enough. I got the Drivo II because the last trainer had a different fault (just one of these things, so I paid the extra and moved up to this).

Frankly it’s rubbish, and unless there’s a proper fix, does anyone know if this is returnable for refund in this scenario? the reason I use that language rubbish is that it looks like from a search that it’s been reported for months, and there are NO firmware updates and as far as I can tell no acknowledgement from Elite

For anyone in the same boat with and Elite Drivo II that doesn’t work (in terms of being slow to change resistance and therefore power output suffers) - I’ve now completed a test using Elite’s MyEtraining software.

That confirmed (with possibly plus, or minus one second error here) it takes 7s for this Elite Drivo II to start ramping up resistance and it completes the ramp up at about 17s. Similar when going back down in power.

Using a test workout of:
2 minutes at 110w
30s at 100w
30s at 180w
30s at 100w
30s at 180w
Using a consistent 90rpm cadence and power smoothing set to zero in advanced settings. Noting Elite have not formally clarified what power smoothing should be set to. In theory zero should mean power readings are instant. That may change if they reply.

The issue is with the parameters set in the Drivo which should be fixed in a firmwatre update. Elite has been talking about firmware updates since years and still not there. However, small ring or big ring makes no difference. In ERG it is better to use the small ring but the delay will still be there.
The only way to solve this, is to contact the assistance, they’ll ask to do a test which consists in building a custom workout in myEtraining App, composed by the following 1min blocks: 100w, 200w, 100w, 300w, 100w, 350w (try to keep a steady cadence).
Then you’ll need to extract that workout in CSV and send it by email with the Drivo II serial number; so I suggest you do it in advance to avoid losing time (they are not very quick in replying).
After that they will be able to give you further instructions, however it is fixable after they change the Drivo parameters but it is definitely a bug, cause it seems not all Drivo II owners have the same problem, so most probably there’s different versions of the firmware around.
Hope this helps.

@Pato that’s really helpful thanks.

If they don’t reply I’ll just return mine. This is a huge worry for future reliability and support for one of the most expensive trainers on the market. I’m actually amazed that a company producing something like this can’t provide users with a method of updating firmware settings. Or even simply providing a setting in the user settings for it.

I learn something new every day though.

Ps. A minute at 300 and 350. Oh that’s not good… lol

That’s at my limit !!!

1 Like

Hi all. In a bid to centralise the breadth of this provlemif you feel so minded and have this problem with delayed responses from the Drivo II (or Drivo) please add your name / pseudonym to a message in Elites forum.
I’ve created it so that Elite see that we can all seee it’s a wide problem so if you either are happy to put your name to a list of frustrated people or just let me know and I’ll do it.
The link to the thread is here
Elite Drivo Drivo II not working
For the Elite Drivo and Drivo II ERG (resistance too slow to change) issue.
Drivo Drivo II ERG resistance

Updated 7/2
Elite customer services replied today abut the Drivo II being very poor in EARG resistance response - hopefully we’ll get a collective response on the Drivo and Drivo II issue (where basically they don’t live up to the claims made - and are really slow to respond in ERG)

Hi Bastiaan. Can let’s see those videos showing the issues?! Thanks in advance.

Hi Francesco,

What are you going to do with the videos?

If you wrote “I have some video’s available to show the issues.” i assume you can let’s see those videos to show us the bug you aren referring to. That’s all.

Yes I do have them available. But I was testing the device for a cycling blog.

If you like, I can share them with you. How do you want to arrange this?

I sent to you a pm.
So i would glad to watch your videos to leave to you my opinion about, and of course, i’m curious to compare your bugs with mine.
Thanks in advance.

I have the Drivo and would experience the delay when using Zwift in Erg Mode, no issues when not using Erg mode.
I also use another program called Ergvideo which is my goto for erg workouts. There is minimal delay (1-2 Secs) in the power ramp up so 10-15 sprint intervals are doable. It also holds the wattage you need unlike Zwift that lets it vary +/- of the target. Maybe that is part of the issue. So at least for my trainer Zwift seems to be part of the problem.

Trainer - Elite Drivo with cadence

I suggest ‘Drivo’ is sarcasm used by Elite to emphasize how slow any resistance change are executed by electric motors of the trainer.
For my Elite Drivo (firmware revision 3) it takes it takes 3s to start ramping up resistance and it completes the ramp up at about 7s, both in Sim mode and Erg mode.

I’ve tried directly changing resistance using myEtraining app. The resistance starts ramping up almost immediately in this case, however it takes maybe 10s to adjust from the minimal to maximum resistance.
I’ve tried doing ERG workouts in Xert and myEtraining, riding SIM mode in Zwift and Rouvy, connecting Ant+ and Bluetooth… There is no single hint that Zwift should be blamed. The trainer is just slow and its firmware implementing FE-C protocol is bugged.
Elite support lives in some other reality where their trainers don’t have issues. They fail not only to provide any firmware update but fail to register any bug.
Any workaround with cadence sensor, using powermatch and setting power smoothing failed for me.

Seriously, the trainer that is failing Zwift ERG mode training sessions cause it couldn’t handle it in time shouldn’t be advertised as Zwift compatible.