Erg mode with Cycleops Magnus

Hi

For several months now erg mode has not been working on my Cycleops Magnus. It used to sort of work in this past summer but then it got really bad and so I gave up and stopped doing workouts. Recently (last week) I calibrated my trainer (using the saris app) and tried an erg (group) workout. Once again, less than 5 minutes into the workout, erg mode screwed up again and I quit the workout and went on a free ride instead.

When I used erg mode the most recent time the resistance, as it was in the summer, felt very “non-linear” and the pedal stroke/wheel rotation felt weird, making it very difficult to maintain a steady cadence. Soon afterwards It got even worse and the resistance got cranked up really high with the "non-linear"ness getting even worse. At that point I quit the workout and gave up on erg mode once again.

I also get the same non-linear resistance effect on steep climbs when the resistance is set to more than 30-40% which is why I usually keep it set to around 25%.

Is there any way to fix this?

Thank you
Aaron

Hi aaron, that sound strange.

What trainer tire are you using and do you have enough pressure. What bike and gearing do you use, some trainers cant produce high torque at low speed.

I use a Vittoria Zaffiro pro slick rear tire. I have a Look 675 Light with 50-34 Praxis chainrings and an 11-28 Shimano 105 cassette.

Thanks, ok that eliminate the gearing and tire options. :thinking:

Have you tried ERG using the Rouvy app.

One other thing do you ANT+? If you use ANT+ the you should use the FE-C options for power and controllable.

I use bluetooth on my Macbook air. And no, I have not used the Rouvy app.

1 Like