ERG mode when pairing directly with Apple TV

Today when I chose a course and did a ride I noticed after awhile that Zwift was automatically adjusting the resistance of my trainer when the incline changed…I’m a newbie and I guess this is referred to as ERG mode. However, this is the first time it’s done this to me, and after playing around with it a bit I realized it was due to the fact that I was pairing my devices directly to my Apple TV, whereas if I paid via the Zwift Companion app ERG mode is turned off…which is my preference. Also, in either case I am not presented any sort of option for toggling ERG mode on and off, despite seeing articles/videos to the contrary. Anyone experience this and can explain why this is happening?

If the resistance was changing due to changes in the gradient of the road, this is called ‘sim’ mode (short for simulation), and is, at least in theory, supposed to mimic actually riding outside. In ERG mode, on the other hand, the resistance is adjusted by the trainer without respect to road gradient, but instead in response to the combination of your gearing and cadence, so that your power output is constant.

I am not really sure how to turn ERG mode off and on manually (I only use it during workouts) on Apple TV, but I don’t think it should make any difference whether you are pairing through the companion app or directly with the ATV, unless you’re exceeding the ATV limit of two Bluetooth connections.

No, I’m pretty sure I was in ERG mode since I never felt compelled to shift gears regardless of the gradient, whereas my preference is to feel more resistance when starting a climb so that I can shift to a lower gear.

Have you checked the Trainer Difficulty slider in the settings? Be sure it is all the way to the right. What trainer are you using?

I’m using a Wahoo Kickr. I’ve never touched the trainer difficulty setting, so it’s still stuck in the middle position. Don’t think that’s the issue, though, because as I mentioned earlier there is a distinct difference when pairing directly with the Apple TV vs. through the Zwift Companion app. When paired through the app I feel the gradient changes instantly as they change; whereas when paired directly I might as well just close my eyes and ride because the resistance always feels the same regardless of the gradient.

It shouldn’t matter which way you pair, direct to the Apple TV or via Companion app. If the Kickr is paired as Controllable, the behavior should be the same. That is, the trainer will adjust resistance based on gradient.

If the resistance feels the same regardless of gradient, then you do not have the trainer paired as Controllable or something else is wrong.

Paired directly to the Apple TV, you are limited to two Bluetooth connections. The Kickr is one such connection. If you pair the Kickr as power, controllable, and cadence (depending on Kickr model), that is only one connection. So, you would still have one more connection for your HRM.

Double check that the Kickr is paired as controllable.

Same problem here. I zwifted on my laptop before, and bought an Apple TV 4k for Zwift. Yesterday I did a race and no mather what gradient I rode, I didn’t had to use my shifters. On my laptop I can “feel” the mountain, and shift back, like in real life. Yesterday I didn’t have to shift at all (only my speed declined uphill).
I double checked my settings this morning, but controlable was connected to my smarttrainer.

Added: I got a Tacx Flux 2 T2980, and a hearthratemonitor from 4iiii Viiiiva HRM ANT+ to BT Bridge, both connected with bluetooth.

1 Like

Interesting, and I guess a bit comforting to hear that it’s more than just me :grinning:

You might want to try pairing via Zwift Companion and see if that makes a difference. Or maybe it was just temporary glitch or something with Zwift or perhaps a bug that will be fixed with the latest update that is supposed be available soon on Apple devices.

1 Like

There do seem to be quite a few complaints related to connecting to Zwift since the last update, so you might want to scan through the Forum and look at those to see if there are any solutions. I think in one of them Zwift had acknowledged the issue and was ‘working on it’. I don’t know if your issue is the same, but there’s a chance.

I found a post about ERG. Don’t know if this is related, but I guess so. Seems ERG is auto on, without an option to turn it off. Have to say I’m not making a study out of it. Will work with my laptop, untill the problem is solved.

Tnx for replying though.

Bob_Lee

Allready got the problem figured out? or working you’re way around it?

No, that problem magically disappeared for me…could have been something flakey going on with Zwift that day. But I’ve also been having problems with HRM accuracy when pairing directly with my Apple TV, so for the past couple of days I’ve just given up and paired via Zwift Companion.