Erg stays on in free ride mode

Hi all, I have the Wahoo kickr core trainer which is giving me a problem. When I first used it erg mode stayed off and I could use my gears to climb and accelerate with changes to the gradient giving the experience a real feel. I did a workout and since then it’s been stuck in erg mode. I didn’t change and settings and never adjusted the trainer but I’ve noticed the Bluetooth light staying solid and not flashing like it use to, once it’s connected to zwift.

I can’t find a way of turning off erg mode on zwift. What am I doing wrong and how can I get erg turned off?

Probably something simple I’m missing. Thanks in advance. Jamie.

ERG mode is not active in free ride.

Is what you are saying that you are no longer getting variance in resistance from the trainer on hills etc.?

Try disconnecting and reconnecting “controllable” or whatever it’s called when you connect everything as you boot up.

Also check your “trainer difficulty” in settings once in-game is not set to 0% (slider all the way to the left) as this disables resistance changes on hills.

edit: or might be related to this if using apple tv: Zwift resistance, hills etc working fine on windows, not iPhone or Apple TV


If you are using iOS you need to force quit the app or pull the plug on Apple TV each time

1 Like

That’s what it was. The initial link up from trainer to zwift. Connecting ‘controllable’. I never used that before as it looked like my old Cycleops trainer. Thought it was for that. :joy::joy:
It works just great now. Thanks a lot Ben. :+1:

1 Like