ERG mode stopped working in workout mode [March 2024] [1.60]

Hi there,

I am experiencing the same issue, ERG mode not functioning in work out mode, the resistance does not change. I am in week 8 of the Build up training plan and everything worked fine up until about 2 weeks ago.

I am using the iPhone app directly with BT. I also use Wahoo System app and ERG mode works with that app no problem. I have tried all the usual troubleshooting but nothing seems to work.

Any suggestions?

iPhone: 17.4
Zwift app: 1.59.0
Trainer: Stac Zero

Hi @Nick_Harrison3! I want to thank you for completing the troubleshooting steps to get the ERG mode functioning. I’d like to kindly ask if you already confirmed the following:

  • Your trainer is paired with Power, Cadence, and Controllable and on only either Bluetooth (BLE) or ANT+
  • If you’re using the Zwift Companion as a bridge, please try uninstalling the Zwift Companion (ZC) app and reinstalling it, but do not uninstall the Zwift Game.
  • Verify your trainer’s firmware is up to date.

Please give these steps a try. In case you’re still unable to use ERG mode in workouts, do not hesitate to reach out to us at support@zwift.com, we’ll be glad to continue assisting you.

Thanks for the reply.

I’m using only BT directly to my iPhone. I am not using the companion app.
My trainers FW is the most recent. The trainer and ERG mode work fine using the Wahoo System app. ERG mode also works in the trainers native app.

I also tried on a MAC using my iPhone as a bridge with the Companion app using BT only. I had the same issue. ERG mode didn’t work in workout mode.

When I try to manually add or take away ERG during a work the scale goes up and down on the your app but the trainer does not respond. It’s seems to be stuck at about 180 watts…

Any other thoughts?

Same trouble with the Stac Zero trainer here, did this issue get resolved?

Hi @harmsway, Welcome to Zwift Forums!

Could you please provide a little bit more details about the specific issues you’re experiencing? If it’s ERG mode-related issue, I would recommend you to check you have the most up-to-date firmware for your trainer. Depending on your trainer, firmware updates can typically be installed from the manufacturer’s app. For more troubleshooting steps please, have a look at this article.Additonaly, please ensure you’re running latest zwift game version. On iOs currently running 1.62.0. For more details on how to update it please, review these steps.

Checked the firmware and game updates.
My Staczero halcyon does show up on the screen but not as a “controllable” trainer since the last Zwift update.
Is the halcyon still a supported device?

Kevin

Have you asked STAC Zero about this? I bet if all of their users are having this problem they will know about it.

HI,
I use the Zwift Hub One and I checked the firmware is up to date via the Companion App. Also the Zwift App on my Windows PC is up to date with the latest version. I checked this as well.
When I start the Build Me Up workout (I am in week 3) the resistance is not changing although everything is connected. Until last week everything work perfectly well.
I uninstalled the Companion App and re-installed the same and used it as a bridge to connect to the PC App.
Same result - resistance did not change. The Erg Mode is not working.
I also started the workout from the selection screen and clicked on Erg Mode on. Again Erg Mode did not work.
Until 3rd April everything worked normally. This is the date of my last Build Me Up Workout.

I just tried to do a normal ride in Watopia. My Click Gear was connected and I could change gears. But this did not have an impact on resistance at all.
What could be the problem?

Any chance you have logged into the game on more than one device? Diverted pairing is a very common problem in that situation (also lost rides, lost levels, etc). If that’s what happened, pick one and delete the game from the other. Consider contacting support directly if you can’t resolve it.

HI, thanks for your advice. I have not logged on to the same or any other game twice.
I always stopped the workout and tried a different approach to make sure I test all suggested steps.
Now I uninstalled the PC app and reinstalled it. Let’s see whether this does the trick.

When you reinstalled, did you delete the preferences files? If not, that’s another thing to try.

https://support.zwift.com/en_us/resetting-your-game-preferences-Syem2NvlP

right now updates are being installed. So I hope that I just opened the App in a weird way and all updates were missing which is now causing the ErgMode problem. If this is not solving the issue I’ll try the deletion of preference files.
It is a bit tedious to find the root cause though.

nope. Neither re-installing the PC App nor deleting the files from documents folder helped.
Erg Mode is still not working.

How can I contact support directly?

Do battle with the chat bot until it prompts you to open a support case. It can be a tedious process but keep at it and you should win the fight eventually. https://www.zwift.com/contact-us

This is still happening for me. I’ve since stopped using Zwift and moved back to “Wahoo System”, everything is working as expected on that side.

I’ll open a ticket as well so they have more points of reference.

Hi,

I used the support Zwift Email and described the problem, all options I underwent to make Erg Mode to work, took a screenshot from the connection status and made a short video where I cycled, but no wattage changes.

I did this yesterday and today and a few minutes ago I received confirmation that a new hub is on its way to me.
I also received a shipping label for sending the defect hub back.

I was surprised by the fastness of the reaction.
I hope the new hub last longer than 2 months although it seems to be a repaired one.

1 Like