ERG Mode in normal ride


(A Oosthuizen (C)) #1

Some time ago I did a workout program during which I used ERG mode. But since then I have noticed that I seem to be stuck in ERG mode for ALL rides. With all the research I’ve done I’m fairly confident that you can only use ERG mode during workouts in Zwift so I am very confused to say the least. The trainer (Kickr) behaves normal using other software such as Rouvy, Bkool, RGT etc. 

Anybody ever experienced this?


(David K) #2

There are a few known issues that may be affecting your Kickr.
https://support.zwift.com/hc/en-us/articles/205486705-KICKR-Troubleshooting

One of the main ones, your Kickr may not change resistance correctly if you’re also running other fitness apps at the same time.

When you have a moment, please exit Zwift and any other fitness software you have running. If you have your Kickr paired in any other software aside from Zwift, please unpair it, then exit.

Use your official support app to check for new firmware updates and complete a new calibration. Afterward, if need be; unpair your Kickr from the official app and exit it.

Finally, double-check that no other apps are running, then load up Zwift. Try to skip calibration in Zwift itself, but give it a test ride. If you’re still noticing resistance issues, please submit an email support ticket to support@zwift.com and attach any log files you have.
https://support.zwift.com/hc/en-us/articles/115001875746-How-do-I-find-my-log-files-

Ride On!


(A Oosthuizen (C)) #3

Thanks David. Been there, done that. Maybe my post wasn’t too clear. It is not about the kickr not changing resistance correctly, it is about zwift not relinquishing control over HOW it is done i.e. it is stuck in ERG when I use zwift. Also as I mentioned very clearly this is only when I use zwift, any other app works just fine.

Read On!


(David K) #4

Not long after adding my response, I found out many of our other members were noticing something similar. It looks like our last update removed the ERG mode selection from the Workout screen in Zwift.

I’ve been told our Developers should have a fix or patch released within a week that should repair the concern. However, until then, if you have an Android or Apple SmartPhone, Zwift Companion allows the option to switch between ERG and SIM mode, and that still works.


(Eddy Van de Walle) #5

Hello, I have the same issue in free ride!  I love to ride in SIM mode on the Kickr, but Zwift always seems to put the Kickr in ERG mode…


(A Oosthuizen (C)) #6

Eddy my problem was eventually resolved with the Innsbruck update. I just made peace with the fact that it is what it is and was quite surprised when I started riding and found the experience very different to what I have gotten use to.

One thing that I think came with the Innsbruck update was the different pairing screen where there is a separate pairing option for smart trainers. Try unpairing and pairing again and see if this makes a difference. 


(Eddy Van de Walle) #7

The best for me would be, in the pairing screen or directly after it, to have an explicit ERG or SIM choice, just to prevent Zwift from implicitly choosing ERG.

I’m not at home now, but I will check with Kinomap whether I have the same issue.  Then I can verify whether it is rather a Wahoo issue or not.