ERG Mode Always Disabled?

As of late, every time I do a structured workout ERG mode is disabled. The companion app shows ‘Incline’ and I have to click it to turn on ERG mode.

This wasn’t always the case… before every time I started a structured workout it would always be in ERG mode by default. It took me awhile to figure out why ERG wasn’t working.

Did something change? How can I make it so that ERG mode is on by default in workouts again?



Do you used ANT+ or Bluetooth.

Do you pair as Power and controllable? If using ANT+ you have to use the FE-c option.

I have both and have tried both.

I don’t know if this is related to the fact that I’ve started running workouts recently as well? Or if I accidently hit something that disabled erg mode by default as an account wide server persisted setting.

For my last few workouts I was opening the companion app and tapping the “incline” option from the in-game companion app sub menu and that would re-enable erg mode.

Last night, I host a weekly Tuesday group ride where we often do individual workouts with keep everyone together, the companion app wouldn’t show me the workout menu. Presumably becuase I was doing a workout in the meetup.

I quickly googled a solution and discovered the up key + clicking erg mode on could also re-enable it.

So I don’t know if doing it via the companion app before was “for this session only” and if what I did last night was “forever on my account” as I haven’t ridden yet today to try.

But the issue was that everytime I load up a workout, erg is off until manually enabled. On Bluetooth or ant (with pairing the FEC devices). I’ve been using both for almost 2 years with no issue, this behaviour is a new-to-me thing. Once erg is manually enabled it works fine, I just don’t know why the default behaviour is now off in workouts when it used to be on.



I don’t know of a way to set the default.

Do you use any other software while Zwifting.

Not while Zwifting nope… I have used RGT in the past week because I was having performance issues with zwift and OpenGL w/ windows and had to change the GPU in the machine (which is slightly better… but oh how I wish Zwift was Vulkan compatible).

I’ll run down now and start a workout to see if ERG mode is on or off by default after toggling it in game last night… one minute. 12 minutes before a meeting.

So yes, it looks like setting the property in game last night has persisted today (where the companion app did not).

I just loaded up a workout and ERG mode was on by default.

I suspect a couple of things.

  1. Doing a run workout (without ERG) interferes with this setting and will break it when I do my lunch run (untested)

  2. I disabled ERG for a sprint workout and/or by accident and this ended up being the end result. Companion app ERG ON setting is “for this session only” where as the in game toggle writes something locally/account wide to ensure it stays on.

I’ve noticed the same thing. ERG use to be checked in the WO screen by default for me. Default has been ERG disabled now for quite some time ime. I find this annoying.

I pair via ZCA BT on a gaming PC running Win11.

I seem to have fixed it by toggling ERG mode on the game (Up Arrow + Clicking ERG) rather than enabling it in the companion app (doesn’t persist the setting beyond the current workout) in my experience.