Entering events

I’m struggling to join any events/rides/races. I’ve recently signed up so I’m a new zwift user. I’ve watched video tutorials and I don’t see anything that leads me in the direction of what I might be doing wrong.

I am using a Wattbike
I am at work on an oil rig, in the gym.
I’m registered to WiFi on the rig through my iPad and running the zwift app on that
I am also registered onto the same WiFi network with my mobile phone and running the companion app on that.

I open the app on the iPad, and find an event to join (any event, just trying to get this thing working) and then start riding and wait for my invite to join the event to come through, but it never does.

I’ve also tried joining events well in advance through the companion app and then starting riding at the time, just before the event and no invite comes up for the event. I check on the companion app and I can see the event has started.

Another thing I have noticed, when I just pic a world and start randomly riding, there is never any other users, I am I’m riding alone through a virtual ghost world. When it comes to a segment, a sprint or climb etc, then the leader board appears and I get awarded a place onto it according to my time, but never see any other virtual riders.

Tried all sorts, as much as I can think to try, to rectify this, but getting nowhere and run out of ideas.

Hoping someone can help!
Thanks

Seeing no other riders usually indicates a connection problem to Zwift’s servers. Could it be that a firewall is preventing access? Something is fundamentally wrong if you never see anyone else.

I suppose it could be a firewall issue, but would that not prevent me accessing zwift altogether?

Zwift uses different ports for various items it can be that only that port is blocked. I’m not a network guy so my terms may be not 100% correct.

I thought of that, and it’s a good point. As well as what Gerrie points out, about the different ports used, it could be also different servers for login and then for actually riding.

All the scenery and stuff is on your local end, so you can ride around a world without the connection working.

It sounds like I might have to get in touch with the IT guys then, thanks for the help.

Zwift must be connected in someway as the segment leaderboards come up and my rides upload to Strava when completed.

https://support.zwift.com/en_us/check-your-internet-connection-error-SJtFv63fr says

Your router firewall should allow all incoming/outgoing Zwift TCP traffic on ports 80 and 443 and all Zwift incoming UDP traffic on port 3022.

TCP 80 and 443 are the ports for normal http/s so probably it’s the UDP port 3022 that is the problem.

4 Likes