Elite Real Turbo Muin b+ (2016), bluetooth and ant+ dropping signal


(Carlos Sanchez) #1

I’ve just purchased a Real Turbo Muin b+ because of the low noise and precision that I had read.

Unfortunately I cannot be more regretful about my decision, since the trainer seems to drop the Bluetooth or ant+ signal frequently and the power changes in ERG mode in Zwift seem to have a 5+ seconds delay.

Over the last two weeks, I’ve done a series of tests with ipad, mac, iphone 7 and a PC (alienware), putting the ipad/iphone/pc closer to the electronics even on top of the electronic board and the problem doesn’t improve.

With e-training iphone app there are no delays in power and no bluetooth signal drops and that’s why at Elite support say it is a Zwift problem so nothing they can do.

In Zwift, with any device I have tried it’s impossible to use this trainer since there is a blueetoth or ant+ drop every 20 seconds to 1 minute maximum, first cadence goes off and then power meter is lost (probably because of the 3 sec average power). With the Mac or PC laptop it is a bit better. In all cases it is impossible to do series in ERG mode since it takes +5 seconds to the Elite to react to a change in power target and if it happens to occur a power bluetooth drop then it means that it is even more time. Races impossible, since the rider stops and then you cannot catch up the group.

I have used in the same setup a Wahoo Kickr and a TACX Bushido without any drops at all so cannot be that my pain cave is full of noise.

I have no idea what to do, and with Elite guys just avoiding any responsibility (I was expecting a bit more from Elite), I am about to give up and buy other unit from other brand, any similar experience?IMG_0116


(Vincent W.) #2

Sorry to hear you’re experiencing these dropouts! Can you try troubleshooting your BLE and ANT + connections with the steps in these guides:

BLE - https://support.zwift.com/en_us/my-bluetooth-signal-is-dropping-running--BJkESEzU7

ANT + - https://support.zwift.com/en_us/my-ant-signal-is-dropping-running--SktF2_orX

I’d also recommend sending your log files to our support team here: https://support.zwift.com/hc/en-us/requests/new

Hope to hear from you soon!


(Jason Filer) #3

I also have this trainer and it is rock solid for me (might be a sligtly newer model) on bluetooth to an Ipad and Iphone (companion). I assume you are using the Misuro B+ cadence/speed sensor? Is it located in the right place? On mine it sits inside a little plastic housing on the bott right of the flywheel housing. Things to check are if the battery is ok and that the sensor has been set to the right number of flashes for the serial number of your trainer. There are useful guides and forum posts on the Elite site.


(Carlos Sanchez) #4

Thank you, my model doesn’t have the Misuro, it already has the bluetooth/ant+ from factory, I think I have read all forums already and no clue what to do now.


(Mario Montminy) #5

Same problem here with the same trainer. Works fine with a PC and an ant+ dongle, but with the apple tv I am experiencing drops. I tried all the suggestions given here, I even put the apple tv near (a few inches) from the trainer, and I still have dropouts.

Any ideas someone?


(Carl Van Tittelboom (bzr) ) #6

Have the same problem here With the same trainer, it is hard or impossible to do race or FTP, tried to connect With ble and With ant+ both are the Same, they all have the delay


(Rémy Blanchard) #7

I have the same problem when y try to connect my Real Turbo Muin B+ with my Wahoo heart rate but when i have connect only the Real Turbo Muin B+ on the BLE and the Wahoo heart rate whit Ant+ the problem was solved.

Do you have try to connect just the Real Turbo Muin B+ whithout oder devices…


(Carl Van Tittelboom (bzr) ) #8

Yes tried it already, i tried even Without putting On the resistance control, then the problem slightly Gets better, But it still has Some moment that it freezes, But if you have to turn down all those things What is the point of having a high tech. Roller? Then you can buy a cheap roller and you can do Just the same With it. :pensive: