Elite Direto changes resistance during FTP test

Dear Zwift community and maybe Zwift support.

I am riding on a 2year old Elite Direto since a month. I pair to Zwift via Bluetooth on an Apple iPad Pro.

Just before the Direto I tested a Kickr 2016 and was really happy with both trainer and Zwift. FTP was estimated to be around 270, and workouts with this level worked well.

I could not keep he Kickr so I changed to the Direto. First thing I noticed is what other people have observed as well: When going towards a mountain, the resistance regulation over-shoots at the first 1-2 sec, and then under-shoots before regulating into normal resistance. The reported wattage is “correct” with a delay. Meaning the first 2 sec I am actually at low wattage while feeling a lot resistance, the next 2 sec I free-spin while wattage goes through the roof.
This is not feeling well, but I can live with it. During a group ride I got always dropped at the beginning of incline (or incline changes) but overtake everybody just 2 sec after. This is obviously a communication delay PLUS a misregulated resistance from the trainer.

In Erg mode during workouts all is fine. And I do not have the problem of other users that there is NO Resistance with Direto.

BUT now I wanted to make a new FTP test.
While in the beginning of the workout until the FTP section all is fine, during the FTP test, there is an annoying bug.
The FTP session should be without resistance changes, thus without Erg mode. Yet while I pedal smoothly, there is a constant small change in resistance. It is 1-2sec just a bit up, then 1-2sec just a bit down and so on. That is very frustrating during a test. I ride on what I think I can hold for 20min, then the resistance (on same rhythm) drives me over that, giving me pain in my legs. Next is it goes down and my legs get a rest while I do not achieve my threshold value. And so on… I had to stop the test because I cannot hold this for more than 5min…

So I went switched off the trainer, on again, paired new, calibrated both in Zwift and in myETraining app from Elite. I also tried changing the “power smoothening” between 5 and 1. Nothing helped

I then went back to Zwift and switched off the “steerable trainer” to drive it as “dumb trainer” and regulate watts myself.
Strange thing: It happened again! Even in a block before where I should hold wattage for 2min over my FTP, there was a constant change in resistance.
I could see that on the wattage output as well…

Any tipps on what I could try?


Hi everybody.

I found some other user that had kind of similar problems on SufferFest. The SufferFest Support said the following:

So I’ve been reading lots today on the Elite Direto. It seems that the flywheel magnets are what causes this issue. It is very sensitive to changes in cadence and the magnets shift to keep the flywheel spinning smoothly. This gives you that oscillating resistance feeling that you are describing. There’s technically nothing wrong with the trainer, it’s more of a matter of how to deal with it so that you feel it less.
Having a separate cadence sensor will improve your experience.
Keeping the flywheel speed up will decrease the oscillation resistance that you are feeling. Smooth cadence increases and power changes will probably work best.

Do you think this could be the problem? And what can I do to prevent this from happening? Or what would be software hacks to avoid it?

There’s an option in the direto settings, for how many pedal strokes it’s averaging your power over.

The default I think is 10, that’s why it lags. If you reduce that number/setting the power numbers will change faster. Too low and you’ll have trouble holding steady power, too high and it’ll lag.

Thanks for the comment.
However I think it does not fit the purpose.
I read this advice before. I changed it from 5 to 2 and then to 1 but nothing helped… in another forum it was actually suggested to INCREASE that value to 10, so that there would NOT be constant data exchange and allow some smoothening of gradient changes…

But what I describe is actually something else.
When I do an FTP test it SHOULD NOT AT ALL regulate resistance, no matter how much he signals back and forth… But during the FTP 20min segment, he does change resistance just a bit up and down every 1-2 sec…
I then actually coupled the device as Power meter BUT NOT as smart trainer. So that Zwift does not even try to send the device some commands on regulating resistance. Again, resistance gets shifted up and down every 1-2sec…

TO me the description makes sense that when pedalling at high power, the flywheel gets more speed at the peak of the pedal stroke and less at the low points of the legs. Therefore it is not running perfectly round. A device could try to make it round by having more resistance at the peak and less at the low. But if that affects pedalling, it is just annoying…

Anyone having similar issues? Any solutions? Any software hacks?

Or do I misunderstand something completely?

I have the exact same issue, also with Elite Direto.
I’ve contacted Zwift and Elite, but found no solution.

I’ve stopped using Zwift since spring and wanted to give the FTP test another try this week. But unfortunately the problem is still there. Impossible to do a good FTP test this way.

Like you said, even in situations where there should be no resistance changes, they are still there.
eg. free ride with trainer sensitivity turned off
I’m sure the resistance changes are there because I have a noisy Direto and I can hear the stepping motor very well.

I am in constant exchange with Elite Support. At least they are responsive to the issue.

However, they are not helpful. They just say: There SHOULD BE NO resistance change. If there is it is a PROBLEM OF THE APP.
They suggest another app is making the trainer change resistance, but I am sure this is not the case.

Zwift instead says it is the Trainer and their software is not to blame…

I tried the Elite trainer on a normal Level Test (one fixed resistance, no change expected) and indeed then it does not change resistance. I want to try it for an FTP test on the Elite app, but did not find the time yet.

I still find the most likely explanation the one I found in a SufferFest forum, where the SufferFest tech guys said the Elite is constantly checking how round the flywheel spins. And if that is not round because of unequal power input, the resistance tries to balance the spinning.
But that means it is a trainer-internal computational feature.
When I asked Elite Support, they say this thing is not existent. They say resistance change ONLY come from Apps…

Any help or other comments greatly appreciated!

I had the exact same conversation and did the same test with the Elite app on Level mode. This test was successful: no resistance changes (and no sound from the stepping motor).

I have not tried a separate cadence sensor yet. Did you give this a try?

Yes, I have a Tacx Speed and Cadence sensor. No change from one to the other.
I also tried not to couple the Elite to Zwift except for reporting Power (Powermeter, NOT as Smart Trainer, NOT as Cadence device). No change.

I re-calibrated 3x and changed this Power Smoothening from everything between 1-10. I am now at 5-7 as it gives a better feeling in Zwift. The 1 or 2 was fun, because every small spike was recorded. That was best to “draw” a power curve that also SHOWS the phenomenon we experience, but unfortunately the tool does not plot the resistance change directly.

Hi zwift Support again.
I write because the issue is not settled. AND because I hope you take a bit more analytical data in Zwift Academy group rides, maybe also for the trainers :slight_smile:

I took part in the yesterdays “ZA Workout #3: 20sec maximal Power” at 7.30pm European time.
My performance is logged on Zwift, Zwiftpower and Todays Plan.
I write you because yesterdays workout I made roughly half with Erg mode ON, but made Erg mode OFF before the sprint settings. The reason is that I like it better to shift gears for the short efforts instead of “waiting” for the erg resistance to be regulated.

During the 25sec “free ride” maximal efforts, with Erg mode anyways off, the Elite Direto changed resistance again!
I was 10sec in the sprint when resistance kicked up, almost driving me out of my shoes. But 1-2sec later, as I just adapted to the lower cadence, resistance would drop again…
This happened on both sprint segments, both with Erg mode manually off.

Can you check this issue again?

PS: Elite support says if the Elite is working in THEIR APP on “level mode” correctly, it is a fault of Zwift. They say there CANNOT be any resistance change unless requested from the trainer app…