Doesn't start after update / Mac


(Konrad Konrad (RadSportKollektiv)) #1

Hi there,

My Zwift doesn’t start after update 10/4/2016. After asking for my password it says “Login sucseccfully”, then it hangs! Tried with ANT±stick and/or bluetooth. Mobile link shows power data for one second, then quits

MacBook Pro OS 10.8.5

At least give me the beta account for the iOS-app , so I can ride.

Thanks in advance,

Konrad


(Juan M. Casillas) #2

Me too. Not a problem with watopia (today) or richmond (yesterday). I Think it’s a serious bug (two days without trainning).

 

:frowning:


(Jon Mayfield) #3

So neither of you ever see the device pairing screen?

Are you both also running Zwift Mobile Link?


(Juan M. Casillas) #4

Hi Jon,

 

I open a ticket two days ago. I’m not running Zwift Mobile Link, neither using Bluetooth. To clarify my steps:

 

1 Run Zwift

2 Log In screen appears. Type in email, passwd …

3 Login successfully

4 Zwift Crashes.

 

Test scenarios:

  1. ANT+ dongle connected, BT enable (as usual for the last year :P)

  2. No ANT+, dongle BT connected.

  3. No ANT+, no BT dongle.

Always without Zwift Mobile running.

 

All the test scenarios work the same: Zwift crashes with the same core dump stack trace. In the opened ticked, Eric is digging in the core dump and some clues start pointing to some Bluetooth code (Maybe in the initialization part of the bluetooth stack).

 

Hope I can help,

Kind Regards,

 

 

 

 


(Jon Mayfield) #5

I’ve dug through your info just now and I think I see exactly why it’s crashing. I’ll get an engineer on a fix in the morning.  We don’t test 8 year old macs in our QA lab so this one slipped under the radar.

Can I offer you an iOS beta invite in the meantime? Do you have a device with an A7 chip or later (iPhone 5S or later, iPad Air or later)?

 


(Konrad Konrad (RadSportKollektiv)) #6

I tried almost every combination:

with / without MobileLink

with / without Bluetooth

with / without ANT

after restart and after re-install.

Hardware specs: Macbook pro i5, 2,5 GHz 4GB, GPU: Intel HD4000 512MB

can I delete the config-files?


(Konrad Konrad (RadSportKollektiv)) #7

I also take a iOS-beta. As long as I can ride tomorrow, because the forecast says “rain”. thanks


(Juan M. Casillas) #8

Hi Jon,

 

Thank you so much for your help ! My 10.8.5 is somewhat old but still powerful machine, maybe it’s time to upgrade the OS to anything more modern.

It’s something weird, because all your released patches work flawlessly everytime. Maybe it’s some related with the OS Bluetooth API? Something has changed in 10.10, and it’s not backward compatible with 10.8?

Just for curiosity, you have checked the differences in the BT layer source code between the two latest released patches? 

 

Thanks for the iOS beta… but I haven’t anything with this chipset :confused: (Ipad2 user, with old Nexus 4 phone :)). But thank you very much again for your offer.

 

Kind Regards,

 

 

 


(Jon Mayfield) #9

Juan, somebody will post back in here or in your support ticket with info once we can figure out what is going on.  There could be a couple of causes.  Sorry for the trouble.

King Konrad, check your inbox :slight_smile:


(Sam Bacon (TCC) A) #10

Exact same issue here, have submitted a ticket. Just before pairing screen it quits on me no matter what I try!


(Henrik Marvig) #11

Got a Tacx Neo today, can´t even install Zwift on my mac. Running a MacBook Air with sierra, the installations just crash all the time :frowning:

Will try on my older MacBook Pro later… but that one my son is using, so I can’t use it for zwift later.


(J oJoGermundi WRCC) #12

Is a solution coming soon for Mac OS X 10.8.5?  If not, is there any way to get a previous release that worked?

I installed on Mac OS X 10.8.5 from scratch on 10/10/2016 and experience the same crash after login.


(samir gupta) #13

Im having the exact same problem since the 10/4/16 update. Mac OS 10.8.5 on MacBook Air

 


(Paul White) #14

Exact same problem. Mac OS 10.7.5. Worked fine when I was last using Zwift in May. Just signed up again today to use now the weather has turned for the worse in  the UK and it crashes just after the Log-in successful screen. Have sent a support ticket in. Mac is completely up to date with softaware updates. 

Whats gone wrong… sorry not very computer savvy so please try and reply in simple terms…


(Ck B) #15

Hi, I was using zwift successfully for 2 weeks. Then this past Sunday, it stopped working. It freezes on the screen where you pair the devices and then proceeds to shut down the entire computer. I have uninstalled and reinstalled the program both times (each time removing all old files and documents pre-instal) and to no avail. It still crashes the ENTIRE computer. My internet is the fastest that is available so that is also not an issue. I turned off drop box, in case that was interfering. But this was also not a problem. I have submitted a ticket twice now, but all I have been told is my issue has been passed on to another person who can help me. 

Thanks for your help in advance. 


(Jon Mayfield) #16

Kelley, what kind of computer do you have?  If a machine is totally turning off that typically means there’s something wrong with a part of the computer - in this case - probably the graphics card or processor overheating or not having enough power from the power supply causing the machine to freeze/reboot.   Some people have found that cleaning air vents or trying the laptop unplugged vs plugged in can make a difference.


(Ronald Asuncion) #17

Dear Jon,

 

I am currently using Macbook Pro , I have installed Zwift application and it was working fine. But since the last update that Zwift app have done, it does not work anymore.

It show the user Name and i can not proceed by clicking RIDE button and it’s still hangs.


(Eric Oshlo) #18

Ronald,

It may not be the same issue, but I have seen a similar effect on my Macbook Pro whereby Zwift on a Mac begins requiring a double click to activate a button rather than the expected single click. 

The cure generally is to click somewhere outside the Zwift window to switch to a different app or the desktop and then click back inside the Zwift window and go from there. You might give that a try.