Crit City lap counter not working [SOLVED]

I’ve only done a few races on Crit City and all have been the bell lap, but the lap counter doesn’t seem to be working.

It absolutely drives me nuts that this doesn’t work in the races.

1 Like

at least the blue distance to go is there at the top of the screen, or I would have no idea when I was on the last lap and if the sprint was coming up.

@Mike_Rowe_KZOO.velo
Thanks for report. The screengrab is always helpful. Our QA team is looking into it.

2 Likes

Lap counter does not work when the event is set to distance.

1 Like

It’s never worked in events to my recollection.

I did a Crit City race yesterday (after the latest update) and the counter worked in that race. This was a Zwift Crit City race, anti-clockwise, and the race was 8 laps. Mind you, I only saw it once as I was too gassed to notice it on the other laps.

I don’t think I’ve ever seen it work before though. This is the first race where I’ve noticed the counter actually working.

1 Like

Hi all on this thread - couple updates:

  1. The image above looks like it’s from a distance-based event, not a lap-based event. If that what it was, the lap counter intentionally will not work.
  2. Our QA team tested this on lap-based events, and it works at it should.

Would you pay attention to the lap counter on your next lap-based race in Crit City and report back? Otherwise, Imma mark this solved.

1 Like

Hi @shooj, the image I posted was from a lap based race, aren’t they all lap based on crit city?

I’m told there are distance-based events in Crit City.

In Zwift companion, can you scroll back to the the date / time of that event? I’m curious now how it was set up.

This is the zwiftpower description, I’ll look in the ZCA too.

ZCA: looks like it was distance

Ok then.Thanks for digging and documenting for posterity.

Imma re-mark as solved.

2 Likes