Crashes when selecting workout

Just did update. Logged on and when choosing workout program freezes and becomes non responsive.Tried 6 times.

Checked workout file in zwift programs but nothing there other than .wad file.

Works as long as I don’t try to use a workout.

I’ve got the same problem here since the last update. I just uninstalled and make a fresh install,no change. It just crashes when I selec “Workouts”

1 Like

I’m having the same problem. The whole app crashes when I click “select workout”

1 Like

Ah shoot, just made another topic stating the exact same issue.
Posting repro steps and other info that might be helpful to dev team:

Repro Steps:

  1. Start zwift
  2. Pair sensors
  3. Continue to the select world screen and click training – Crash occurs here

Same with if I load into the world, and select the workout button from the menu. Very frustrating :frowning:
Something potentially related from my log file:

[18:49:33] Loading WAD file ‘assets/Workouts/workouts.wad’ with file.
[18:49:33] Tried to load a valid xml file, but it seems to not really be a ZWO file?
[18:49:33] LoadWorkout failed to load.
This occurs for all of the xml files in the trainingPlans file.

Have had response from support and appears to only be a PC issue and they are on to it. I used my iPad and did a workout today no problems.

Hopefully they will have a fix shortly.

There’s already a new update that fixes the workout issue. I guess iPad is not affected since it doesn’t have the face update yet.

Still a problem with Apple TV…

1 Like

Are you still having the problem?
Just started my indoor season today and i have exactly the same problem with my ATV😩

I had the same issue this morning with apple TV … app crashed and need to restart … Rest was working fine

Got this from Zwift about an hour ago. I have been mailing with the support since last night and sent them videos of the problem so, hopefully they will solve the problem soon.

1 Like

It’s only Wednesday! Just not training for a few days? That bites!