Couldn't join race today

Today I registered for race " THE COALITION - Chase To The Underground" (3695135) from the Zwift app. About 15 minutes before the race I started my warmup on Tempus Fugit. On that screen at the lower left was the “Menu” button. Above this there normally would have been “Your event starts in 15:00 minutes” with a button beneath “Join Event”. However, neither of these last two was present.
I then exited Tempus Fugit with about 10 minutes remaining and tried Volcano Circuit – same result.
I then rechecked the app to assure that I was indeed registered.
After the race finished, Zwiftpower showed that multiple riders had finished so they didn’t have this problem.

Is there some new way of joining a race or what did I do wrong? (200+ races without this problem.)

Note – This is a dedicated Zwift computer. I had rebooted this computer before starting Zwift for a relatively clean setup. (I normally do this.)

Don C.

Hi @Don_Culp

I have this happen if you register for the race in the companion app while in the menu screen of the game.

If this happen again you should unregister in the companion app while warming up and then re register. But Let’s hope it does not happen again.

I was completely outside of Zwift when I registered on the app.

If it makes any difference, when I later started Zwift I was asked to login which I did without a problem. (I’m occasionally asked to login but not sure why. I always run from the same computer.)

This happens to me probably once a month and has done so for as long as I can remember. I unjoin the event in Companion and re-enter in Companion. Then the tile appears in the game.