Connecting to Kicker with Ant+ but no movement in zwift


(El Senor) #1

I have had so many issues with getting zwift to work with BT that I got the ant+ dongle from wahoo.  It was working great for a few weeks but yesterday something happened.  

I log into zwift and everything connects except it’s showing zero watts.  Now I’m not sure if this is a kicker issue or a zwift issue.  Regardless, in the game, the guy doesn’t move at all.  I’m assuming that this is because it’s showing zero watts.  

Here’s what I’ve done so far.  Shut down and unplug everything (mac, dongle, kicker).  Give it a few minutes.  Start it all up again and still same zero watt.  I gave it a night and tried again this am.  Same issues.  Any ideas?


(Paul Allen) #2

Connect it to the Wahoo app on your phone and see if it is broadcasting any watts.


(David K) #3

When checking out your connections, I noticed sometime around May 14th, when your Wahoo was connecting, it wasn’t reporting paired in quite the same way.

When you have a chance, I’d recommend unpairing your trainer from the Paired Devices screen in Zwift by tapping each blue square to turn it back to orange. Afterward, completely exit Zwift.

In your official trainer support app, pair your Wahoo, check for any avaliable firmware updates, and complete a new calibration. After that, unpair from your official Wahoo support app and exit it. Force stop the app if need be, then unplug your Wahoo for about 8 minutes.

This would also be a good time to disconnect your ANT+ USB Dongle from your MacBook and give it a full reboot. Once you’re back in OSX, plug in your ANT+ Dongle again and make sure it’s detected. Afterward, open Zwift and pair your Wahoo again as both Power Source and Controllable. Try to avoid completing a calibration in Zwift and try a ride.

Let us know if it’s still not moving your avatar in game.