Computrainer - Pairing then dissapears

My Computrainers suddenly does not work in zwift anymore. I launch Zwift goes to paring screen and for a couple of seconds it shows up as “power devices” then goes away.

Does anyone else have similar troubles or ideas how to fix this ?

I use the ftdi usb to stereo adapter to connect my CT to my PC.

As a backup solution i can use the PerfPRO CT smart bridge , and choose “dynastream” as power source and controllable trainer but before yesterday i always have been able to connect directly to my computrainer. (I know this solution “locks” up the com port / ftdi usb slot so I understand that the CT will not show up in pairing screen when this is running - i always restart my pc before alternating between these connection methods)

I have checked my computer , no new windows updates or driver updates have been installed so that should not be the problem.

Any ideas ?

Try a different COMM port? Go up 9 or so.

Thanks for the tip, but same result! Changed com port to port 10 , rebooted , no difference.

Dead FTDI? Does PerfPro use the stereo cable for connection?

Have you visually checked all cable, even the DIN?

PerfPro does use the same stereo cable and USB FTDI connection, and with that everything works.
So I am able to use zwift as always, I just have to use the PerfPro as a proxy solution.

It’s a solution but not a “clean” one in my mind.

Might you have a laptop or other computer to install Zwift on as a check?

Could PerfPro have changed something?

Can you run the RM1 software?

So , i installed Zwift on my laptop and connected the USB FTDI adapter to it , turned on my CT and Zwift pairs as it should with my trainer. Everything OK (on my laptop).

I guess this means that there are some software issue on my desktop, probably with zwift since other training systems detect my trainer on the desktop.

I have already uninstalled zwift (has been installed since 2015) , but I didnt remove all files & directories before i installed it again. It detected under installation that the installation folder was not empty but i went trough with the installation anyway.

Maybe ill uninstall , remove the zwift folder under program files (x86) and install again.

Should i also clear the zwift files that are under “My Documents” ?

Thanks for all the help so far :wink:

Those are your saved files. You could add old to the folder name so the install will create a new folder but you’ll still have the files just in case.

A fresh install can’t hurt.

Fresh install did not help. But when i renamed the zwift folder under my documents and restarted it worked out ok.

So that was the solution this time :slight_smile:

Success! Glad it’s working.