Computrainer no signal


(Tony Hoch) #1

Seconds after detecting my computrainer, speed, heart rate and cadence change to no signal. Any ideas?


(N ightTrain) #2

are you using the “Power” or “Speed” option when selecting equipment? I had originally selected my computrainer under speed. Zwift would populate the other fields but give me the “no signal” warning (odd, since my computrainer programs worked well). Once I started to select it under “power” first, all other sensors were populated for computrainer and things started to work (of course, I also pulled new FTDI drivers from racermate at the same time, so don’t know which one was the real fix).


(Jeff Abbott) #3

I always just use the Power option (and not the speed). This has been working fine for me.
You dont have another app like racermate open in the background as well do you?


(Mike Baldinger) #4

I have the same issue. It finds my Computrainer on COM3 but it says No Signal


(Henric Meldgard) #5

I’m having the same issue.  latest FTDI driver, changed the com port from 3 to 4,  no programs running in the background.   pairing using the power option (the speed option seems to churn away and never finds the computrainer).  zwift support doesn’t seem to be going anywhere.

 

any thoughts?


(Michael McDonagh) #6

Same here.  It used to work flawlessly (like 6 months ago and more), even with 2 Computrainers connected to the computer.  Now, it is very hit or miss, and most of the time it says “No Signal”.  Sometimes I have to unplug one of the Computrainers for Zwift to even find any of them.  Sometimes I can’t get Zwift to connect at all, which means I am wasting my $10 per month.  I always select via “Power Source”.

I have always been running Zwift on Windows 10. Is it possible some of the updates to Windows has caused a problem? 

I am using the FTDI driver from Racermate. At one point, Windows Update updated the FTDI driver, and it caused issues, so I reverted to the Racermate one.  But now, I don’t know what try.  What have people done to resolve this?


(Henric Meldgard) #7

Hi

I was using a fairly old model computrainer but with the 3D software.  I could not get it to work with zwift at all.  I upraded the contoller chip and went to the new One software and the problem solved.  I think it had more to do with the chip than with the software. I am running win7 OS.  Hope that is of some help.


(Ray Ruyack) #8

Latest FTDI driver I have is 2.12.16.0.  I have no problems with that version.  Be sure all cables are fully seated, DIN especially.  See if the 3D or RM1 software works.  If it doesn’t go to the RacerMate Forum and see if there are answers there.  Check your DIN cable for wear.  Sometimes it gets moved about and near the rear tire.  RacerMate Forum - http://www.racermate.net/forum/

 


(Michael McDonagh) #9

Thanks for tips, Henric and Ray. I checked all cables and everything is tight.  When I launch the CompuTrainer 3D software, both CompuTrainers are discovered and work with the software simultaneously.

I had version 2.12.0.0 (8/26/2014) of the FTDI drivers installed.  Today I let Windows update the drivers to version 2.12.16.0 (3/19/2016), but this did not help.  So then I was reading the Zwift support page on setting up a CompuTrainer and saw the link to download the FTDI driver for Windows, and in the link I could see that it was version 2.10.0, older than the two I have recently tried.  So I downloaded the 2.10 version, then had to manually update the driver since it was an older version.  Now with this driver version, when I launch Zwift I can see both CompuTrainers and I can select either one and so far it does not appear to drop the signal, so the problem is probably solved. This 2.10 driver may have been the version I was using before the problems started, since Windows may have automatically updated the driver along the way.

There is still one remaining problem, albeit a minor one.  If I select the wrong CompuTrainer, then unpair it and try to pair with the other one, neither of them show up as options anymore and I am dead in the water.  (I am pretty sure this was not an issue before when everything used to work flawlessly.)  Closing Zwift and restarting it does not help, I still cannot pair with either one.  However, if I launch CompuTrainer 3D (for which the CT’s always work great), close it, then relaunch Zwift, I am again able to select either CT.  So as long I select the CT I want in Zwift and don’t unpair it, it works fine (so far).  But there is clearly still some unreliability present.  My CT head units both have chip version 25.43.


(Ray Ruyack) #10

It may be that the comm ports are not releasing.  Loading the 3D software frees the ports up which then allows Zwift to see them separately.  Just a theory…

Maybe move one port up high, like comm 12 or something as sort of a test.


(Chris Bolling - Draft) #11

I was very annoyed this morning with the same problem… no signal. What I found was that I had to select the trainer through the “Controllable Trainer” box and “Power Source” box and then the problem went away. Something changed where it is not populating in both automagically. I will try the driver update next to see if both will populate. I was getting the same issue on two different computrainers and two different computers.
The most interesting thing is that after riding Computrainers for more than 15 years with the plus and minus buttons, I can barely stomach a ride without Zwift. Thank you Zwift team for your creation!
Happy Zwifting.


(Dee Makepeace) #12

Had a similar issue.  Zwift worked fine until a couple of days ago and then suddenly it stopped working with my CT.  I always used to pair through the Power Source and it worked fine.  Today I tried pairing via the Controllable Trainer instead and now it seems to work fine.  Hopefully it stays working fine.

 

 


(Tom Brutsaert) #13

Same issue for me.  Zwift worked fine with CT for several weeks.  Now, I cannot pair.  I use Mac.   Is the basic approach to resolution to try and download new FTDI drivers?


(Susie Wyrick) #14

I’m having the same issues with 1 of my computrainer. My husbands computrainer works great always but mine comes and goes. Once I change ports, I’m usually ok. However this time didn’t work. In Oder for me to bike, I have to change ports every time I ride. I’m currently waiting for zwift to answer and help me out. Everything fully updated


(Ray Ruyack) #15

What comm port are you using?  If high, >10, try using a port below 10.


(Susie Wyrick) #16

Done that. Thanks for the suggestion though.

 

susie