Companion fails to add to calendar

The companion app claims it needs full access to add an event to my iOS calendar, when my settings are set to “Add events only”. This setting should suffice for adding events to the calendar. I’m aware Zwift won’t be able to remove events from my calendar with this setting.

Same issue here. It got worse after reinstalling the app, as now the app does not show Calendar access in Settings.

1 Like

Yeah, same with me

Same here, both on iPhone 14 Pro Max and iPad Air 3.
iPadOS 17.0.2 and iOS 17.0.2.

Full access is granted. App version is 3.51.0 on both devices.

Same here. I don’t want to give ZC full access to everything in my calendar. Please make ZC work with ‘Add events only’.

1 Like

3.51.1 is working fine again for me.

I changed my settings to “ask” and now it works as before

1 Like

Same here on ios 17.0.2 and 3.51.1 app version

where do you make the change to “ask”? Is that an iOS setting or somewhere in the Zwift Companion App? Thanks for the help!

Hi Joshua

Go to settings, notifications, events

Let me know if you need more help

Thank you for the help. Sorry if I’m being dumb: on iPhone Settings → Notifications
Then there is a Notification Style by app but no events selection under Companion (Zwift)

This is what I see in Android

Just tried to creat a calendar entry for a ride and couldn’t because ZC wanted Full access not just event access to my calendar. That’s a new issue since the calendar setting has been event only access all along. Has something changed? I’m not giving full access when an event access is sufficient.

Can this be fixed,

Thank you.

Maria

This has been a longstanding issue, however the release notes for Companion 3.54 indicate a change that might possibly be related:

(@shooj) I just started experiencing what appears to be a similar issue as others: with the update to iOS Companion v3.54.0 my prior calendar setting of “Add Events Only” under iOS settings is now insufficient to allow Companion to add events to my calendar. I temporarily switched iOS ZCA calendar permissions to “Full Access” and confirmed that ZCA could then add events to my calendar, but this is a (hopefully unintended) change from past ZCA calendar access requirements.

Hopefully this’ll be remedied in a future ZCA version release, and in the meantime I’ve reverted permission back to “Add Events Only” as I prefer to manually add events to my calendar over giving Zwift unnecessary full read/write access to all my personal calendar events and info.

Can confirm I have the same problem. I’m testing on iOS 17.4 (21E5195e)

I am also having the same issues with Zwift Companion on iPhone 15 Pro on iOS 17.4.

I do not see an Ask to Add Event option under settings in iOS notifications or in the Zwift Companion app.