Companion App Won't Open [SOLVED]

For the last two days, my companion app has not been opening, and if it does open, it is only after I do a soft reset on my phone. I had deleted and reinstalled the app twice. I submitted a service request to zwift.

After like an hour of opening and closing the app, it finally decides to open, and I go about my ride. Fast forward to today, and now it won’t open at all (even if I do a soft reset of my phone).

Any help would be appreciated. I’m at a loss!

What device are you running the companion on? Are you on the latest version of the app (iOS version 3.12.1 don’t have android so don’t know that one)?

I’m running iOS 13.4.1

No the app version. 3.12.1 is showing as the most up to date version of the companion.

I really don’t know. The app won’t open so that I can see what version it is.

Anthony M Spencer

Go to the App Store and search for Zwift Companion. If it says “open” you have the latest version. If it says “get” you are running an out of date version and should update it.

Well in that case I have the latest version. This is the screen it’s stuck on since earlier this afternoon and even now when I open it. Hopefully support will get back to me soon!

Anthony M Spencer
Sent from my iPhone

Let us know when you get an answer. I’m leaning towards an issue between the latest iOS and the companion app. I’m still running iOS 13.3.1 and haven’t run across issues. I’ll hold off on upgrading the iOS for now I guess.

Will Do….Thanks

Anthony M Spencer



@Anthony_Spencer_HERD I flagged this one up to our QA team to investigate.

The Zwift Companion app is super stable, and we seldom see reports of it failing to launch. We’re just as eager to see what’s up with this.

For context - is this a work-issued iPhone? Are there any VPN / firewall / malware apps or other security-related processes running on it?

Okay, so this is my personal iPhone with McAfee security installed on it, and it would seem this comes with a VPN. No sooner than I turn it off, companion app opens right up.

Apparently Zwift Companion doesn’t like VPN very much!

Odd though, because I have had McAfee installed for like a month now and hadn’t noticed issues until just recently!

Anyways, it works, so…

1 Like

@Anthony_Spencer_HERD thanks for the report and closing the loop. We’re glad to hear it’s working!

I am getting “the version you are trying to run is out of date” yet when I go to the App Store I get Open, which implies I have the newest version. I’ve tried shutting down the app, no; I’ve tried rebooting the iPhone (also newest iOS), No; I’ve tried deleting the app and reinstalling, No

I guess I’m going to Zwift without the Companion… wasted almost an hour of riding time…

I just got the same issue. All working this morning during race. Now tried to open companion app and it says it needs an update but when I go to App Store there isn’t an update.

Same issue on Android after latest version update… keeps requesting latest update, but play store has latest version installed

Still not working for me on iOS on iphone.I’ve not even got VPN turned either.

Mine just started working again. iPhone

Mine opened but wouldn’t connect to my activity. I thought maybe it was because the phone was picking cellular over the WiFi so turned off cellular but it persisted. Anyone else have this issue?

Just had exactly the same problem Daniel. Companion wouldn’t connect to the activity I was doing, even though it showed that I was riding in the activity list.