Companion app no longer adding events to calendar

I’m using the companion app (v. 3.31.0) on Android and as of yesterday, it no longer prompts me to add an event to my calendar when I register for an event. I tried manually changing the “Create Event Reminders” setting to “Always” and set “Event Reminder Defaults” to set a reminder and export to my calendar, but nothing happens when I join an event. Is anybody else having this problem?

I am having the same issue. It started happening within the last week. I have not made any changes to my settings either. It is sort of annoying because when I am chasing around the kids on the weekend, it is nice to have the 30 minute reminder to get my stuff together for an event that I joined!

3 Likes

There was a companion app update last week, maybe it got reset on your device for some reason? Try changing the settings in the companion app under “Notifications” to send the calendar invites again.

Mine is still working as usual, Android version.

2 Likes

Have just changed the notification setting and it adds to my calendar, pretty sure it was doing this since the update though.

What does happen when you unselected the event the calendar entry is not deleted from the calendar as it use to do.

Android phone.

1 Like

So, just tried for a race at 12:30 EST and noticing that nothing was even sent to my Google Calendar. I checked for the WTRL race I am doing on Wednesday and that too was not sent to my calendar. I confirmed that the settings are enabled to send update to my e-mail (which is my calendar email) and other reminder settings are also there.

I get not getting the Google Calendar notification, if it is not synced. What I do not get is that I do not get the Zwift notification either.

Google Pixel 3A, Android 12

1 Like

@Mike_Rowe1 as I mentioned in my original post, I tried manually changing the settings after noticing the problem and it still doesn’t work.

2 Likes

Hi @Kate, sorry I was replying to Richard’s post.

1 Like

It may be related to the calendar permission not being requested again during the companion app update.
I logged out, uninstalled the app, restarted phone, logged in, and changed the notification setting in the app to remind and add to calendar. That triggered a system permission request on my phone, even though it previously had been working.

I previously did the above without restarting and that did not trigger the system permission request.

2 Likes

Ok, I tried this - sort of - and it looks like it might be working.

I went into settings and revoked Calendar permission. Cleared my cache and restarted the app. I registered for an event and it was added to my calendar! It was a little slow, but in reality, I will usually sign up hours in advance.

Strange that the update cleared the connection without the permission being revoked…

Thanks for the idea!!

2 Likes

Glad it worked! I missed a good number of events bc I forgot about them not being on my calendar before I eventually sat down to figure out a fix.

I tried @Richard_Barnhill 's solution, and even uninstalled and reinstalled the app, but unfortunately that didn’t work for me. However, I did notice something interesting. Just for fun, I toggled the “create event reminder” setting to “ask” and then joined an event. The app did not ask if I wanted to create a reminder. This seems like something’s broken.

1 Like

Yeah, I was gonna circle back here today to mention that I joined a noon group ride today and surprise to me - it was not added to my calendar despite yesterday, it clearly working again. Back to square one…

1st January 2022 - same bug for me for the past several days (couple of weeks). Advice to uninstall/reinstall is useless. Installing on a second device does not help. Nor does clearing cache/storage. The bug remains.

I also see followed Zwifters allegedly Zwifting non stop, day after day, but they are not on Zwift presently and have no recently saved Zwift activities. Heather Fell is one example.

This app is definitely broken.

1 Like

I’m having the same problem, all authorisations are there

Try this: Companion app - no notifications on Android - #7 by Dave_ZPCMR

Followed all of that too. Definitely a bug

Looks like this started working again with the latest update. At least, I did nothing and received the alerts like normal - so I’ll call that a win!

Still doesn’t prompt for me, and there isn’t an update.

Update out, still broken.

The Tour de Zwift filter in the events section is also returning a “network error” and no events are showing until I turn off the filter.