Companion app - no notifications on Android

For several days I have not received notifications for the start of an event. I’ve installed on a second device - same result. I’ve uninstalled/reinstalled on my phone. No improvement. If I change settings to ask to set a reminder I am not asked. Even though I have specified additions to my calendar, none are added. If I set to default 15 minute reminders there still are none. App is allowed to run in background, battery optimisation disabled, app not closed. It does not help.

This was all working OK until mid December. Then I had some days away from Zwift and now reminders are completely broken. I have to use Alexa to set reminders for my rides. The app is useless.

Tim it happened to my wife’s phone when we got new phones. I had to go in and change all her notification settings and reinstall the app a few times. Keep trying. Goid luck. I don’t remember what setting fixed it.

Thanks, Gerrie. I’ve had this phone for around 15 months, so definitely not new. It’s running stock Samsung Android 11 firmware, with only the December security patch as a recent update. I will fiddle with notification settings and hope it fixes itself. Although as an ex IT guy I think that is a crap way of resolving the problem. Wings and prayers should not be required.

1 Like

Hmm. Cleared cache and storage, reset permissions and signed in again. First event correctly offered a reminder and calendar entry, which worked as expected. Second and third events did not prompt to save a reminder and did not add to my calendar.

This looks like an app bug to me.

1 Like

Same issue here. Not being prompted to even set a reminder any more. Setting it to always doesn’t work either. Android app, version 3.31.0.

Clearing app data and logging in again makes no difference.

Changed app permissions to allow calendar access (never needed to do this manually before) and cleared data/logged in again and it worked. Once. Then stopped again, just like Tim’s experience above. Clearly a bug with permissions.

I really wish they’d fix the notification sounds btw. They’ve been broken for years. All you get is the system default sound, not the dedicated app sound.

Found a workaround for this, and it might be one for a Swift Zwift Tip @Shane_Miller_GPLama since I don’t recall knowing about it, even though it’s really obvious in hindsight. :wink:

On the event I’ve joined which didn’t offer me a reminder I noticed that there’s a greyed out clock. Tapping on this clock brings up the reminder settings, allowing you to amend them as needed. You can change the time, add/remove from your calendar and so on. It can be done from the home screen, events list or once you’ve tapped on the event itself - i.e. showing the event description etc.


In the case of this bug, it allows you to manually add a reminder where the app didn’t ask as expected. Tested repeatedly and seems to work fine. I still wouldn’t trust the app itself for a consistent reminder but assuming it adds the event to your calendar correctly, that should be reliable.

And it’s definitely a bug, because once a reminder is set, if you repeatedly leave and rejoin the same event, the reminder options come up as expected. Go try join something else, and there’s no prompt.

4 Likes

I have seen this clock, and an equivalent “calendar” icon, but on a running event starting in three minutes I have had no reminder and now no visible clock/calendar (I guess because there is now insufficient time remaining to set a reminder). I’ve also missed the event.

I did contact support and an “Ambassador” replied, advising to uninstall/reinstall until it works. Genius!

In a binary world that really should not be the answer. I’ve already installed from scratch on a second device, uninstalled/reinstalled on my phone and separately wiped cache/storage and the bug remains. I don’t really see much point in repeating the same troubleshooting steps if the outcome is unaltered. That is the definition of insanity. I am not insane, just frustrated.

Still, once again I will uninstall/reinstall, although I have low hopes for improvement.

Don’t bother reinstalling, it’s definitely broken. But adding the reminder manually is working for me. I can see the event add itself to my calender, and the reminders go off as expected. Likewise if I toggle off the calendar reminder in ZC, upon refreshing my calender it disappears.

When searching I realised this has been reported by others recently: Companion app no longer adding events to calendar

@shooj

1 Like

By the way, I’ve also noticed a couple of people I follow have been on Zwift constantly for days on end, even though they clearly are not. Heather Fell, for example, has been active on Zwift for the past several days and is “Zwifting now”, except she isn’t. I keep giving ride-ons, but her last recorded activity was early December.

This is plainly another bug - appearing yet again following my clean reinstall.