Companion app issues

(Gary Keeley ZZRC ) #1

Anyone got any clue why the companion app has stopped switching to game mode when I’m in an event? It’s happened the last few times ?

Cheers

(Lin) #2

Is your Companion app up to date? How about Zwift?

Now that you mention it, I thought it was taking longer than usual to switch into ride/game mode the last week or so. It takes like 20-30s instead of what I remember being normal as 5-10s. But, it does switch.

(Gary Keeley ZZRC ) #3

I do think it’s all up to date but just this last week it wont switch. Really odd but even 30 mins into a ride still nothing ? Have mailed zwift they may have a solution. Many thanks

(Gerrie Delport TeamODZ) #4

Have you tried to turn flight mode off and on while riding to see if it is not a WIFI issue.

(David Lee Cryo-Gen) #5

My companion app isn’t working either.
Already restarted the phone, still no joy.

(Paul) #6

Can you give us more info.

Is your phone with the ZCA and the device that is running the Zwift app connected to the same router?

(Gary Keeley ZZRC ) #7

Thanks folks had some help from the swift team seems to have sorted the problem.

Thanks as always

(Gerrie Delport TeamODZ) #8

Do you want to share what fixed it for you, this can help other riders that have the same issue.

(Gary Keeley ZZRC ) #9

Sure thing this is a copy of what I received

Hi Gary,

Thanks for reaching out to us at Zwift support.

I’m sorry to hear you’re having issues with the Zwift Companion. I’d like you to try turning on airplane mode to eliminate the chance that your mobile app isn’t trying to connect from mobile data. First, make sure the Zwift Companion app and Zwift are closed, then do one of the following:

  1. Turn off mobile data OR switch your phone to airplane mode. Let me know if you need instructions.
  2. Turn on WiFi and connect to the same network your computer is using.
  3. Turn on BLE, if using it for sensors.
  4. Launch the Zwift Companion app and log in.
  5. Launch the Zwift game and log in.

    ​You should see the Companion app pair to the game. When you say delete the app do you mean the Zwift Companion? If you uninstall the ZC you won’t lose anything. The most that would happen would be having to log in to the app again.

Give that a try, and let me know how it goes!

Ride On.

1 Like
(David Lee Cryo-Gen) #10

Yes and yes.

Fixed itself on Saturday night after I updated Zwift on my Windows laptop.

Took 50 minutes instead of the usual minute to update, missed the race I wanted to do unfortunately.