Companion App hanging in pairing mode

Hi Guys,

I’m running Zwift on a Windows PC with my Android Phone as a Hot Spot for the PC. Both updated to latest version. If I by accident press A on the PC keyboard the App goes into pairing mode and never returnes to normal operation. The App is just stuck in pairing. Even if I toggle the App it returns to the pairing screen. The PC keeps running as normal.

Mark :face_with_peeking_eye:

What happens if you swipe down on the app to refresh it?

what device are you running the CA on?

if android try reloading the CA by swiping down and selecting it from the notifications bar - this usually resets most weirdness for me!

not sure about iOS though

1 Like

I get this with Android as well. I have to exit ZC and restart it. No hotspot involved, both my tablet and Win11 computer are WiFi-connected to the same router.

1 Like

I tried restarting the App which did nothing. As I was in a group ride today I could not disconnect the Hotspot and restart the CA without screwing up my ride.

Perhaps this is a little off-topic, and the problem sounds legitimate, but what led you to do pairing via the Companion app? I wonder if you could get a better experience pairing to the PC. If you have issues with that we could also talk about possible solutions that might be more easily accessible.

I’m actually pairing on my PC. When you pair your devices while the App is started on the phone, the App will actually say Pairing Devices

Weird, what happens if you kill the Companion app on the phone and never start it? Same problem?

Paul, if I clear the CA cache and restart the App I still get the paring info on the CA

What I’m suggesting is to test with no companion app at all. Ensure that’s not running, or delete it entirely, and see what happens. Does pairing on the PC work if Companion is totally absent? If so then this may be some kind of problem related to the Companion app thinking you are pairing by phone and not directly to the PC.

Paul, I just tried inside the house on my home WiFi. My phone on my WiFi running CA and my PC running Zwift. If I am logged in to a world and press A I get the same scenario.

I just figured out what is going on. I have always been pressing ESC to get out of the pairing screen on the PC. If I press SKIP instead then everything is working as it should.
Somehow the function of pressing ESC has changed.