check internet connection?


(Noelani Diemicke) #1

It’s just fine - I even tried changing my password on the site - but the app won’t load. Help???


(Jon Mayfield) #2

Hi Noelani, can you be more specific about what error you are getting? Is this after the game loads at the log-in screen, or are you at the first step where there’s a few pictures that slide past and it might say “updating…”?


(Noelani Diemicke) #3

It kept telling me to check my internet connection after entering my password (did not tell me my password was incorrect) and obviously internet was fine if I could get to site to post this question. After over 20 min of various attempts including resetting my password I rebooted my pc and it worked ok. Still don’t know why it happened


(Ryan Rapolas) #4

I am having the same problem. I have internet connection and login works on the website.


(Noelani Diemicke) #5

Ryan - after lots of options - I finally rebooted my PC and it worked fine - have you tried that?


(Ryan Rapolas) #6

Yea, first thing I tried. I will try it again when I get home.


(Russell Town) #7

I’m having the exact same issue. Have tried numerous reboots - I still enter my password and the check internet connection error appears.

Help!


(Wheelbrother 1) #8

I’m getting the same thing and when I enter my password, it won’t take it, and says “check internet connection” which I did, and it was working fine.
I then rebooted the computer, and still the same thing. I know the password is right because I logged in to leave this response.
Help! I cant ride a trainer anymore without Zwift!


(Ryan Rapolas) #9

I think what fixed it for me was fixing my antivirus running in the background. There was a problem with Comodo giving access to Zwift. Once I allowed this it was fine.


(David Bananosipedist) #10

Same problem in December 2015 here. I had few crashes, but steel could log in and so, now the internet connection error appears.


(Samuel Mendelow) #11

Zwift, I will be specific. I click the Zwift icon, open it, and get the first log in screen where it sometimes says loading, has pictures etc, and type my info in and it logs in, and then goes full screen and shows the blue icon and all the “Zwift’s Vegan”, “Clean up the sweat” stuff and then says logging in with the picture of the island in the background and, then says "Failed to log in. Check internet connection.

Even though my connection is perfect, it logs in on the website, and the first screen, and every other program that uses internet works. I also tried it with my security program completely off, and after rebooting the computer. And I uninstalled Zwift completely from the computer, reinstalled it, it updated etc. and it still gave the same thing, I also tried it with and without my ANT+ dongle plugged in.

Please help, it will run on my desktop, but not my laptop (the computer where the problem I described was) and my laptop is way more powerful and has a good graphics card etc. and I won’t pay for zwift if I can only run it on my desktop because it’s laggy and slow, etc.


(Jon Mayfield) #12

Samuel, I’m not sure how much I’ll be able to help as this is the first time I’ve heard of a situation like this, but it seems like maybe a firewall or anti-virus might be blocking ZwiftApp (the full screen game) from communicating with the network, but not ZwiftAppLauncher (the thing with the login screen and pictures).  

After the game says “Check internet connection” it should pop up a login screen with the game running behind it - if you try to login there does it fail again?

Do you know if you have any extra security software running?


(Samuel Mendelow) #13

Hey Jon,

I reset my computer to factory settings and it worked perfectly, thanks!!


(Matthew Staller) #14

I’m having this issue today, “can’t log in, check internet connection”. Very unwelcome since no settings have changed, running only Windows Defender, etc. etc. I’ve tried several restarts but still can’t log in.


(Ruud van Kooten[HIK]) #15

i’m also having major problems with login in into zwift. i can login into the first screen, after that im can choose between “join now” and “ride” if i click “ride” i get send to the next screen were i have to login again… and thats were the problems start, zwift is telling me that i have to check my internet connection. But my internet connection is perfect, i also checked zwift is getting blocked by my firewall. but that isnt the case. 

 

everything is perfect, zwift is even running on my pc downstairs… on the same internet connection.

 

i bought an Tacx Flux… it cost me 799,- euros. and i cant even use it right now! :( 

zwift support PLEASE help me!