Cat enforcement races signup not working in companion

Just tried signing up to tonight’s Herd Sheries race 2 (7pm bst) and I’m showing restricted for all cats so can’t enter the race at all. Some team members are showing the same for this race and other cat enforcement races. Is there a bug? Is it likely to be resolved in the next couple of hours? Otherwise I need to change my race plans…

One of our riders is having the same issue. Any ideas @James_Zwift ?

1 Like

It’s also not working when I try to sign up online either if that helps

I’m seeing the same thing. My companion app: latest version, latest iOS, iPhone.

Exact same issue here; restricted for all races, all categories

Same for me.

Hi everyone,

We know about this - thank you. Working to fix aSAP.


Should be fixed now. Sorry all!

1 Like

Today I don’t seem to have any categories open to me in cat enforcement races. I’m A, always race A, only want to race A, but even that isn’t open to me today. Anybody else have this?

Same on both CA and in game menu

We know about this and are working to fix as quickly as possible.

Yep, fixed for me. Thanks James and team :slightly_smiling_face:


After last update i cant join any CE race. Its like zwift cant find my old activities.

Can you look into this?


Check if it is working now.

Not sure if related to this, but in my race tonight (I signed up for C last night) the Cs were in the B results in-game and vice versa. As and Ds were in the right places. I show as a C on the unfiltered results.

Edit: not a CE event, so probably not.

I had this experience :

Completely locked out of all Categorys on Windows PC …
On Companion App which I tried after much fiddling about - No Cat Enforcement at all .
Entered then returned to Windows PC and saw same situation . All Categories available to me

Was the around the time the fix was being posted . Was the fix for this to disable cat enforcement for this event ?

If not , maybe there is some other issue now.

Screenshot showing open category choice for me ,

Can’t sign up for this race on the companion app due to the exclamation point. Is this a bug or am I doing something wrong?

I assume you have not been riding in the last 60 days.

Once you do a free ride Zwift will calculate your category.

So go for a nice ride.

Nice ride can be as short as 2km.

I thought the ‘no data’ fallback was going to be A or E only, not no entry whatsoever. That’s pretty confusing for users, tbh.

1 Like

It’s E.

There is no E Category in the event shown above.

1 Like