Can't connect to Kinetic!

Honestly, I don’t know if this is a Zwift issue or a Kinetic issue. I wake up my trainer, connect to it, close the Kinetic app, start Zwift, and it won’t connect. A few times I connected to the power sensor, but not the cadence. I got it to work once, but today it’s not connecting at all.

Trainer: Kinetic Rock&Road Smart 2

Device: LG Velvet

Can anyone help?

Before closing the Kinetic app, go back into the “sensors” menu and disconnect from the trainer.
The app is supposed to end the Bluetooth connection automaticly but I find that it can be variable for some reason.
You can connect to Zwift with Ant + and have both open at the same time.
That allows me to perform multiple calibrations as my trainer gets warmer.

Has anyone had any success with this? I’m having the same issue as the original poster. I’ve tried all combinations of Kinetic app open / closed, InRide sensor connected / disconnected, and I still can’t get Zwift to find the InRide sensor. It just keeps ‘searching’.

I also assume that in Zwift you add the sensor under “power meter”, correct?

Kinetic road machine smart

Is your trainer the kinetic 6400 or does it have an InRide 2 or 3 sensor?
Is it interactive or non interactive?

@James_Mearkle I bet you need the Zwift Companion app. That’s what I needed for my Smart Road 2. Then when you’re in that pairing screen in Zwift, there’s a gear icon in the top right corner where you can pick Zwift Companion.

I just opened the app and it worked.
Well, it opened. I’ll go home and see if I can calibrate.

Could not calibrate, no sensors detected.

That happened to me. It worked after I did the reset procedure for the Kinetic trainers.
Zwift won’t let me post a link here, but a search for “Kinetic pod reset” should find it.

I did the reset and it now works.