Can't connect to Garmin

Today I rode and my activity synced to Strava and TrainingPeaks but not to Garmin (these are the 3 accounts I had connected). I hadn’t ridden on Zwift for couple of months so I don’t know if it’s a recent issue. When I last rode - it was all fine.

I went on the companion app “Connections” screen and Garmin is shown as connected. I went to the website zwift .com/eu/settings/connections and although Garmin was shown as connected, I decided to reconnect. I disconnected but when I tried to connect again, I got infinite loading (see screenshot).

I went the app to reconnect to Garmin there - there is a “+” button to add Garmin but when I click it, it shows loading icon for 1-2 sec and then it stops. Nothing happens, no error message.

Is the integration broken for anyone else?

Try disconnecting and reconnecting here: The at Home Cycling & Running Virtual Training App

1 Like

That’s where I tried to do it - thus the screenshot. But it worked now, thank you!

I tried from a different computer however and I noticed that the link that works contains “/ca/settings/connections”, while the one that didn’t work was “/eu/settings/connections”. Maybe that’s causing the issue?

Sometimes there is a delay in loading to other apps, I had one last week that took a few hours to get in to Garmin.

If it has worked previously I wouldn’t rush to change anything too quickly. Worst comes to worst you can simply download the data file from Strava and load it up in to Garmin, but again, I wouldn’t rush to do that.

Paul.

Others are having issues (my own activities synch fine). You can always synch from Strava to Garmin if it doesn’t get sorted.