Can't connect Direto X with companion app

2 days ago everything worked perfectly. Today companion app doesn’t connect with my Direto X.
I tried to restart the phone, computer, router. Nothing worked. Elite training app and ugprade see the trainer as usual and connect w/o issues. Any tips?

companion app connects over bluetooth Xiaomi Mi 9 Se

Make sure the trainer isn’t still paired to the Elite apps, or directly with your phone, because that will stop them pairing with Zwift Companion.

Can you not pair the trainer directly and not via ZC?

Hi Steve,
I reset my phone and bluetooth connection so Elite apps were not paired when tried with Zwift. Direto X don’t want to pair directly with phone but only through apps.

Yes, I cannot pair directly as I don’t have in my PC neither bluetooth or ant+. It worked great with ZC for 2 months and suddently today I cannot connect.

Hi Robert, thanks for reaching out!

Something that I’d recommend trying is putting your mobile device into airplane mode and turning Wifi on. Connecting to mobile data will interrupt the connection between Zwift Companion and Zwift and will prevent you from pairing using Zwift Companion as a bridge.

Give that a shot and let us know how it goes!

maybe related to my own issue?

Yeah, looks like it’s not only me then.

Hi @Robert_Dudziak

I’m not sure if the Zwift Companion (ZC) app pairing issues have to do with some recent BLE changes made on the server-side, but I’ve reached out to the team to try and get confirmation. I’ll let you know when I have more info!

In the meantime, it wouldn’t hurt to try the standard ZC troubleshooting from this article.


I heard back from the team and it seems we weren’t able to reproduce the same issue you’ve encountered when using the same type of device you’re using for Zwift. Our team also determined that your issue doesn’t seem to be related to any known issues and that it’s likely a Zwift Companion and/or Android issue that needs to be troubleshooted on a case-by-case basis.

That said, is your Xiaomi MI 9 SE Android using Android 12? If so, you may have to go into your Android OS device Settings > Apps > Zwift Companion > Permissions and manually give the ZC app permissions to use Locations.

I hope that helps!

I have the same problem. Downgrade to version 3.31.1

Thanks Steven. None of proposed above solutions works. I will try to Downgrade ZC app as it seems update recent done to ZC app is the issue. I just reviewed many other topics on the forum, where people have the same problem with ZC .

I can confirm, downgrading to 3.31.1 is solution.

So the issue is not my phone, not my trainer but ZC app 3.33 is broken.

Hi @Robert_Dudziak

Thanks for giving those things a try. I’ve again flagged up this issue to the team and I’m working to get more information. I’ll update you when I know more. Thanks again!

Hi @Robert_Dudziak and others impacted by this issue,

I heard back from the team and was able to get confirmation that the issue is still being actively investigated. I have provided some additional commentary here.

Thanks for raising this up to us!

1 Like