Cannot send message on Companion [Jan 2024]

Since the latest updates I can send messages from the pen but when the ride/race starts the message is only on my CA screen, not to the ingame screen.

Are you sure that CA and Zwift are both connected to the same network, also make sure you don’t have a disconnect notice in the top left hand corner on Zwift

Its a new issue. I’ve escalated it.

Its affecting event leaders being able to communicate and others are unable to resound.


Hi Martin,
Had no disconnection on my screen.
Strange thing is that I could send a message from this morning pen at the 3rd stage of Fast is flat but not during the race. Had the same last week at the Pack groupride at Innsbruckring.
Gr Jack

Pretty much ruined the ride I had to lead tonight; maybe 1 in 20 messages went through…

Sending through on keyboard nor companion mattered.


This has been an ongoing issue for a few days now

Widespread issues messages failing yesterday, force close CA helps for one message then can’t again…makes it very difficult for Leaders and Sweepers to do their thing and frustrating for those wanting to chat

1 Like

Yeah, we’ve had the exact same issue on our 3R leads yesterday morning and today. Makes it challenging to lead a group ride. I’m aware of several users on various platforms that have the issue.

Same issue if trying to send messages from the Companion app or directly from in-game by pressing ‘m’ on PC. The client accepts the message but it seems the servers only receive and process 15-20% of messages so only a few of these appear on other riders’ screens.

It’s definitely not the end-user equipment or network at fault. There is something happening in Zwift HQ centrally.

… yeah, that’s how yesterday felt for sure hahaha

Sometimes I’d get lucky and find patterns; like my messages would send at the 20 second markers, and then at the tops of the minutes (not always, but a vast majority).

I hate to say it, but when Zwift fails at one of the primary aspects of why most of us are here, there’s an issue!


I also started recognizing this issue starting Monday January 15, 2024 in the morning CST. It was not present Sunday January 14, 2024 in the morning CST.

I cannot find rhyme nor reason in which messages sent via Companion get through to the group chat and which don’t. Sometimes every other message sometimes every 3 or 4. Maybe there is an elapsed timing element? I believe DM’s between active users all get through, but can’t confirm.

This occurs for me running Companion on an Android 14 phone with the latest Pixel January update, with the latest game release on both ATV and PC.

The current game and Companion releases did not have this issue originally, so I am wondering if this is a server-side change that broke something?

Unfortunately, I experienced a problem with DMs as well. The person I was chatting with would send messages and they would appear on my laptop screen but not in CA app. Only my side of the convo appeared there.

1 Like

Hi all - thanks for the many reports on messages not going through to the game.

Our server team fixed this issue and messages should be working as expected now. Please let us know if you are seeing it’s not.


During the last couple of days, chat in companion has not been transmitting all messages. This has happened on multiple group rides, and based on feedback from other riders, seems to be affecting ALL participants.

Today I could send messages from CA and they came ingame on screen during PACK groupride so problem seems to be solved.


Hi. Try force-closing the Companion app, and opening again.

The companion app is freezing and cant send messages, I will stay on 1 spot on the map, and sometimes it reads nothing in the watts or it will stay at constant values. This has been happening for the last 5ish days for me. It happened again this morning 4 to 7 AM EST. The only thing that fixes it for a short while is restarting my phone.

Yeah I had similar to happen with me on a group ride on friday I think it was, thought it was just me, obviously not

I am also having problems with zwift braking using the zwift play. I normally let them stay green but decided to turn them off after my companion app locked up 2 more times. I dont know what kinda voodoo happened but after I turned the zwift play unit off. I never had another problem. I could chat to my hearts desire, my screen on the companion app never froze, and this might help solve the software problem with the zwift play. I have no idea how it all ties together, but I am now 100% positive it does with todays testing and positive outcome with no brakes and no companion freeze

Yes tested again this morning…I was riding without either of the zwift play controllers hooked up. It worked flawlessly. Then for some reason the right one turned on by itself. I know it sounds bizarre but it 100% happened. Within 15 minutes my companion app froze. I turned it off and for the next hour it worked perfectly. No idea why it turned itself on either. I am now 100% sure what ever is freezing the companion app has something to do with the code with zwift play. It also keeps the neo bike steering from working even though it says it is connected. Overall this is not a very pleasing experience

1 Like

I think you’re talking about a totally different issue to what this thread is about.