Cannot load details of a recent activity

Hi all, yesterday I finished a workout and clicked “save&exit” normally. Then strangely the completed workout was not synchronized to my TrainingPeaks and Strava account (which work perfectly fine previously). I can see the workout on my Zwift activity feed (data was updated to my monthly goals and overall profile as well). However, when I tried to click into the details of the workout, it seems to be loading forever. I also tried on the companion app, it says “error loading details of the activity”. Strangely enough, I can successfully see the details of other workouts. Any idea how I can fix this? Thanks!

I’ve seen the same for some of my rides.

I can’t tell for sure, but my impression is the FIT file upload resulted in corrupt data on Zwift’s servers. It would seem as if Zwift does not sanitize these uploads (else it would have been marked “corrupt” or something like it… or even fixed)

As there is (currently?) no way to manually upload FIT files to Zwift, nor is there a way to delete such rides, you (your activity feed…) are stuck with it forever.

You may be able to upload the file to Strava (or whatever tracking site you use), possibly requiring fitfiletools processing.

1 Like

Thanks very much for the suggestion. I agree with you that yesterday’s data was somehow corrupted during the uploading process. It’s a pity that the “upload” was completely performed by Zwift. Therefore I don’t have access to the .FIT file. Hope they can come up with a solution.

Depending on your Zwift platform, you do have access to past FIT files (see here.)

(the article also describes how to delete past activities - which was new to me…)

1 Like

That’s exactly what I want. Thanks very much!