Cannot connect with controllable Zwift

Hi all!
I just started my ‘Zwifting-carreer’ and bought a setup (Tacx Flux S Smart).

When I start the Zwift software on my laptop (together with the Zwift Companion-app) the connection between the software and Tacx trainer are found imidiatelt for the power and cadance. But for the controllable-function it can’t be found.

After a number of rebooting/restarting I just ride once with the controllable function, but the last tries it’s not connecting. Are there any solutions for this, or how can this be solved? More people with this issue?

Note: I tried connecting with the Companion-app as well with the bluetooth on my laptop.

Hey Sander, sorry to hear Zwift is giving you some pairing trouble! Do you know if your Tacx was ever paired to another app, such as the Tacx training app? If so, try unpairing your trainer from that app and then restart Zwift and attempt to pair controllable again.

If this does not help and you need more assistance feel free to send in a technical support conversation here: https://support.zwift.com/contact/contact-us-HJH8N4RNQ

1 Like

Hi! I have the same problem. Just bought the tacx flux s smart, on the tacx app no problem with resitance. On Zwift no chance to get the “controllable trainer” working. Have tried it 6 times since buying and no chance with all combos connecting/disconnecting.
I heard that with an ANT+ there should be no problem but i would like to have a sweeter solution;)
Thanks beforehand.
Cheers
Mathias

Hi Matthias,

I tried connecting with my tablet (no other Bluetooth connections set) instead of my mobile phone (connections with Android Auto, my smartwatch). And now it works every time.

Maybe you have an other device to connect also?

Hi

Same issue here. Worked perfectly well last season with same setup, but now, it’s almost impossible to connect as controllable trainer. I have a flux smart trainer.

And if i’m lucky enough to get it to connetc as a controllable trainer, it always drops the bt signal mid ride, causing lots of cursing and frustration being dropped from the group.

I have also tried with several android devices. Same issue.

I think something happened in the last game update og companion app update.

Good luck zwifting!

I am having the same issue. I am using the tacx Bushido. Have you found an answer to this problem??? It worked fine originally but now no pairing with controllable.

1 Like

Hello. I have a Tacx Flux and a android phone (S7) with Companion installed.
I’ve had the same intermittent problem : Controllable pairing only happened once in a while. So I found a protocol that succeeds every time, here it is (after 2 months of testing) :

  1. Make sure the Tacx trainer is unplugged, and bluetooth is only enabled on your computer (not on the phone). The Tacx Trainer must be close (within 3 meters) to the computer.
  2. Restart your phone
  3. Start the Companion app on the phone
  4. Start Zwift on the computer
  5. Once the pairing window appears, turn on the Tacx
  6. The three active connections should appear
4 Likes

Thanks for taking the time to respond. I will give this a try. If it works for me as well, I will forward the info onto support so they can make any needed changes to their software.

Blaine

Yes, I got a chance to use your system and it works. Thanks for sharing.

2 Likes

You are welcome. I know how frustrating it can be to miss an event because of a connection failure…
Regards,

Geoff

1 Like

Thanks Geoffrey… can’t wait to try this tomorrow morning. I’ve had some frustrating training rides and see I’m not alone.

after trying to pair thru the companion app this work around was successful at the first attempt. big thumbs up!! thanks

Thank you so so much!!! Ive been pulling my hair out!

Not sure how you worked this out but it works like a charm. Thank you!!

Same problem. Tried the companion work around. Still doesn’t work. I hate zwift btw. I just had to throw that in there. I would like it more if it connected better. It can’t find my HR monitor either. The program sucks. My devices all work and all work in every other setting except zwift

I have the same problem with my Tacx Vortex. The Zwift software pairs with the power and cadence but would not connect the controllable.

It seems to work intermittently… it worked a few days ago but now it will no longer pair.

I tried many combination and sequence to no avail.
I tried the suggested workaround via the Companion on the phone… no luck.

Same thing with me.
This has occured before the latest update of May 2020 but I have the feeling that it has gotten worse since.

Setup:
Tried both iMac and PC / Win10 plus Companion on a Motorola Moto G7plus running Android 10 or on a quite old Samsung tablet.
Power and cadence - yes. Controllable, only rarely.
And if yes, it screws up after being maybe 20 minutes in a ride, dropping down to 0W, which is very frustrating as was already mentioned above.

Polar HR reliably connects via Bluetooth and Companion without any issues.

Running the Zwift app on the phone (not Companion), it immediately recognizes the trainer as controllable.

Edit: also, no loss of connection so far, cycling via phone (Motorola Moto G7plus) - the identical phone with which I keep having issues cycling via Companion …

However, a 15cm screen sort of limits the fun of the whole thing.

Will try Geoffrey’s suggestion. Plus, I have ordered a Bluetooth adapter for the computer for a few bucks.

Martin

1 Like

Following Geoffreys procedure has not helped in my case.

What did help as a workarond for my issues is a Bluetooth 4.0 CSR dongle, bought for six Euro something including shipping. With this, pairing is a matter of a couple of seconds, “controllable” is always immediately there. It works both on my old iMac and on a Windows PC. So far I did two rides for over an hour each and did not experience any loss of signal.
I continue to use companion but not for connecting trainer or HR sensor, just for the in game functions.

Martin