Can’t get my HRM to measure…

I have a brandnew HR40 chestband from IGPSport (it’s compatible with Zwift).

I can pair it without any problems. Zwift registers and accept it fine.

But when I ride, it registers 0 BPM. I’ve tried repairing several times.

I also tested it in another app. It measures perfectly.

What can be causing this?

A few questions:

According to what I’ve found online, your HRM can use Bluetooth 4.0 or ANT+. Which do you use when pairing to Zwift?
What device do you run zwift on? (PC / tablet / Mac / Apple TV, etc.)

When you are in the pairing screen in Zwift (presumably wearing the HR40) does it always show ‘0’ bpm? Or is that only when you are riding?

Is it possible that another app on another device (phone, bike computer), or on your zwifting device, is still open and interfering with the detection of your HR signal? If so, completely close any other apps and/or possibly paired devices and try again with just your main Zwift device.

I’m actually not sure whether I’m using BT or ANT+….hmm…where can I see that?

I’m running Zwift on iPad.

It’s always showing 0 BPM - no matter what I’m doing (riding or just standing beside the bike).

I don’t know if my Apple Watch could be interfering somehow. I’m not using it in any way related to Zwift.

If you’re running Zwift on an iPad, like I always do, too, then you can only be connecting via BT as Apple devices lack the hardware to capture ANT+ signals.

On the pairing screen, you see the BT logo in the HR pairing window and also in the main pairing screen upper left, both circled in red:

I’ve tried to get a 0 bpm reading on my paired HRM (Wahoo TICKR), but can only manage it momentarily when connecting it to another app (Wahoo). From what I understand – and I’m as far from an expert as you’d like to meet :neutral_face: – BT connection behaviour and capabilities vary widely between devices. It could be that your HRM is already actively paired to another connection and needs to be ‘forgotten’ on that one, or at least that connection needs to be broken by force-closing the active app or the device on which it is operating, in order for your heart rate to be readable by Zwift on your iPad.
I’ve read the user manual for your model, but it doesn’t go into any detail about multiple pairing. If it is broadcasting simultaneously via ANT+ to what the manufacturer refers to as the ‘master device’ (your bike computer?), perhaps that is contributing to this problem.

I’m also wearing an Apple Watch, but have never paired it to that iPad, so don’t know if somehow it could be interfering.

If it were me, I would try isolating the problem by:

  • switching off (force closing) any other app and device (including phone, Apple Watch and bike computer) that could be communicating with your HRM,
  • force closing the Zwift app on your iPad,
  • powering off your indoor trainer,
  • powering on your indoor trainer, and
  • restarting Zwift on your iPad and going through the pairing screen procedure.

(This is all assuming that your HRM is operating correctly and that you have a good skin connection with the chest strap pads, etc., which is probable if you’re getting good readings using other devices.)
Wishing you well with this.

From your rides on the Companion app, it looks like you’re getting HR data in Zwift since yesterday.
What helped/worked? Just curious, having studied up on your problem.

I don’t know what precisely did it - I restarted everything (again). Ipad, Apple Watch, Iphone, hometrainer, Tv, Apple TV…yeah even the ventilator/fan placed in front of my bike :smiley: and then also I tried applying some gel to the HRM monitor “measuring pads”…and then suddenly it worked.

So somehow your suggestions helped me in the right direction - and thanks for that :slight_smile:

1 Like

You have to put water at the HRM pad’s before it works, always.