Can’t connect discourse app?

For some reason lately I can’t get the discourse iOS app to respond favorably to the “connect” button. I receive an error: “Authorize application access. Sorry, you do not have the required trust level to access the user API”

I’ve tried deleting and reinstalling the forum into the app, deleting and reinstalling the discourse app. Out of ideas… any suggestions?

IIRC, it’s been that way for about 2wks now. I have the same issue. My best guess is that Zwift updated the forum backend (Discourse) and broke something. I say this because another forum I follow using the Discourse app also reset login credentials on the same day making me think that Discourse pushed out an update to their forum backend. There was no iPhone app update when this happened. I logged back into the other forum w/no issues. However, Zwift has continued to be broken.

1 Like

Zwift replied via support

Thanks for contacting Zwift!

I’m sorry you’re having issues with the Discourse app working with the Zwift Forum.

I’ve done a little research and I found this on the Discourse forum. If I’m reading the forum correctly you haven’t reached the appropriate Trust level to gain access through the Discourse app. This forum thread explains it and what you need to do to gain access. https://meta.discourse.org/t/insufficient-trust-level-to-connect-here-via-the-mobile-app/66859. This is essentially a Discourse issue and not anything Zwift can remedy.

If there’s anything else we can help with, please let us know.

You’ll be receiving an email with a survey about our conversation. Please ignore the survey and respond back to this message if you have any additional questions.

Ride On!

:man_shrugging:

That isn’t the answer in my case if at all.

It was working fine for me for over a year when it suddenly stopped working. Secondly, I am already TL2 or Member.

1 Like

Me too, and wasn’t my issue either. I’d messaged another forum with the issue and they have it fixed already today. I sent back a reply that they should consider ditching the trust requirement to use the iOS app, it seems silly.

It’s not the trust levels need to be removed or lowered, they serve a purpose. Furthermore, getting to TL1 is simple. Question is what broke that results in me not being able to use the Discourse Hub app which I have been using for quite some time.

I might open a support ticket or not. I typically view the forum on a computer via a web browser. Broken app access is annoying but not the end of the world.

Still broken FWIW. Probably worth emailing support, I did but they must need more reports to earn a fix. Pretty annoying.

2 Likes

Stillllll broken.

1 Like

Still broken. Jeez Cmon Zwift….

Authorize application access

Sorry, you do not have the required trust level to access the user API

Same issue here. Been down for months. Will probably open a support ticket

1 Like

Hey all, Trust Levels are built into Discourse for sound security reasons. To use the Discourse app, you must have Trust Level 1. If you’d prefer to use the app instead of using the browser - read 30 posts on this forum, and you reach TL1.

2 Likes

That’s not the problem here. I’m Member since forever but get the same error message as the OP after login in the Discourse app.

2 Likes

As I tried to explain in the past, I’ve been trust level 2/“member” the entire time I’ve been reporting this bug. This is the only discourse forum I’m having this problem with so I have to assume it’s something wrong with this forum config. A quick tap into the others’ profiles also responding here shows us all at basic or member levels so…… I hope this can be figured out soon because it’s a nice app :man_shrugging:

2 Likes