Cadence Unstable


(Ken Mahler) #1

I have tried both a Bluetooth and an ANT+ cadence sensor and my rpm in Zwift is unstable jumping for normal rpms (80-95) to 0 and my rider stops pedaling and then the rpm jumps back to normal continuously.  I have a Wahoo Kickr and I am using the iOS version of Zwift thru my iPad.  The Wahoo Bluetooth cadence sensor works fine in the Wahoo software.  The Ant+ sensor is linked through the 4iiii Viiiiva heart rate monitor.  Any ideas how to get stable rpm in Zwift?  I have move the iPad close to the sensor and is remains unstable.


(Graham Collier CCC) #2

I’m getting the same problem since the last iOS update but with bluetooth and a Tacx Bushido.


(Nicholas Taylor [WKG] Daddy B) #3

Exactly the same problem here with an Elite Qubo digital smart B+ trainer. Regular dropouts, on average once every thirty to forty seconds.


(Ryan Patano) #4

I am having the exact same problem with the Wahoo Cadence sensor connected to a MS Surface with Ant+.  It was very unreliable.  It always showed “paired” but rarely picked up the cadence.  


(Ken Mahler) #5

Has anyone solved this problem yet.  I have replaced sensor batteries and still have unstable rpm.  Sometimes rpm is correct for a few seconds, but then drops to 0 then sometimes jumps to 100+ then back to normal 85-90 (correct value)


(Jacobo Ron WBR (D)) #6

I have the same issue, anyone have a solved it?? I have Wahoo kickr, iPad Air, Wahoo rpm cadence


(Alan Chaikovsky) #7

I have the same issue with BKOOL smart GO


(Hpenasa Hpenasa (Instragram - Strava)) #8

ave the same issue with my wahoo cadence sensor and Kickr16


(Radek Paprocki PLCR) #9

I have same issue with Stages and Bushido. Today I can’t finish my workout. That was horrible. I have bought Viiiiva to make me easier to pair more than 2 sensors with ATV. Anyone has solved it? It seems that is Zwift issue. When I don’t connect my trainer as Controllable, all signals from viiiiva are correct and don’t drop. When I pair my Bushido I have issues.


(Bill Groves (C)) #10

I had the same issue, I have a Tacx Bushido.  The issue occurred on my ipad via Bluetooth and my lap top using ANT Dongle.  I verified that everything was working via Tacx Utility App, Wahoo Utility App, heck I even brought in my Garmin 810 to make sure data was transmitting, and it was.

Contacted Zwift, they promptly replied with suggestions.  Zwift wrote that most cadence issues are caused because of an interfering signal.  

Bottom line, I had too much going on.  Once I made sure all other apps and unnecessary device that can send a signal were either out of rang or off.  The problem went away. 

 


(Radek Paprocki PLCR) #11

No way. I used Stages PM and it works when I connect it directly with ATV, but then I have no HR. When I connect Stages with Bridge Viiiiva I have only issues. In other apps all works great, also Viiiiva isn’t faulty. Sometimes when I’m lucky man all works in Zwift too. I don’t know what I make that it works. I don’t find any similar doing. That’s why I think, that this issue stay from Zwift side and no from Apple or Viiiiva


(Jeff Gabriel) #12

Agree - but think this is a smoothing issue for Zwift related to sensor input rather than a connectivity issue. Seems like it reports every movement but should be taking a smoothed average or other approach to prevent thrashing.


(Ferenc Sagi) #13

I have the same issue. Right now every measurement is 0. 


(Reiko Donato) #14

I was having the same problem with cadence data not getting to Zwift from my Quarq Dzero power meter.  I use my MacBook Pro for Zwift using bluetooth.  After sending diagnostic data to Zwift, I was told that there were many instances of bluetooth interference.  Since the only other source of bluetooth in the room was my iPhone, which I kept on while I rode, I turned off the bluetooth capability of the phone for the last 2 rides, and have been able to get accurate cadence on Zwift without any disruption.  My PM is also connected to my Garmin Edge 520 via ANT+ so I was able to verify the cadence I was seeing on Zwift screen was the same was what I was seen on Garmin.  So if you have more than one device with bluetooth on (even if you are using only one for Zwift), you might want to try turning off bluetooth of all the other devices and see what happens.


(Dan Hjalmarsson) #15

I have the same problem with my  Elite Qubo digital smart B+ connected with ANT+ to Windows 10