BUG - Error in Zwift Companion Connectivity

I am using Zwift App version 1.21.2. an IPad Air with IOS 15.3.
And Companion App v 3.32.0 in an Iphone 12 Pro Max with IOS 15.3
Both in the Same wifi network (a tplink mesh wifi network with 200mb stable internet)

When using it, companion app keeps connecting and disconnecting all the time. It shows the details of the zwift session -power, cadence, etc, then it closes suddenly and go to that screen we see when not connected in the main Zwift.

In the iPad I see below message: Connection Failure

I have tried restart, uninstall both apps and even change to different network without success

Hi @Bruno_Gross, welcome to the forums!

The mesh network is the likely cause. I’ve seen numerous reports of them causing issues with the companion app not able to see the game on the same network. Are you able to force the devices (iphone and ipad) to connect to the same wifi node? That should help.

Hi Bruno, thanks for reaching out!

As a first step to troubleshooting this, I would recommend putting your iPhone in Airplane mode and then turning wifi on! This will prevent your iPhone from connecting to mobile data which would interupt the connection between your Zwift and Zwift Companion causing situations like you have experienced.

Give that a shot and let us know how it goes!

I have been having this same issue since the January update. I have made no changes to my mesh network, nor have I made any changes to the location or orientation of my pain cave. I never had the issue prior to the January update. In addition, my companion app, on iOS iPhone 12, will goto the in-game view when I’m in the course selection menus (I still have the old menu system). I run Zwift from my Win 11 laptop and all sensors to ANT+ except companion app. I, too, have tried deleting and reinstalling the CA but to no avail.


It’s a coincidence that it happened after the update. It’s your network (try rebooting it). Mesh network seem to be sensitive to this. Your Companion device needs to be able to see your Zwift client app device on your network for this to work, so somehow your network isn’t letting this happen. I assume you have Wifi Assist turned off on your phone.

Thanks for the info! I went for a ride immediately after posting about my issues and before that ride I tried the suggestion to turn airplane mode on. That worked - no connection issues whatsoever. I found that I have Wifi Assist turned on so I wonder if turning that off would have the same effect (I suspect it might). It’s strange because my trainer is less than 10 feet from the nearest mesh node. I have noticed some connectivity issues with other devices on the network but rebooting my modem a few days ago seemed to resolve those. I think I will also try rebooting the wifi network devices.

Good to hear that it was fine in Airplane mode. So it’s probably down to Wifi Assist being on. You would think it wouldn’t need to switch to mobile data if you’re pretty close to the router, but strange things can happen sometimes (e.g. radio interference).