Can't connect to companion app since last update

Hi, I Zwift on my Mac laptop (Big Sur, 11.6) and use the companion app on my iPhone (iOS 15.2.1) for the in-game mini map. This has worked essentially fine for months. However, after the most recent Zwift update (last week), my companion app has stopped recognizing when I’m in game and loading the mini map screen. I’ve tried restarting both the Zwift app on the computer, restarting the app on the phone, and rebooting the phone entirely. I’ve tried putting the phone into airplane mode, turning the wi-fi off and back on again, etc. Nothing has worked.

So, how can I pull some logs to figure out what’s going on? For Zwift devs: one slightly complicating issue at my house is I’ve got a mesh network for the WiFi, which shouldn’t be a problem, but I’ve noticed sometimes if I load the companion app on the opposite side of the house from my Zwift computer then it doesn’t recognize things, so what I’ve been doing successfully for months is waiting until I get down to the basement where my Zwift set-up is to launch the Zwift app. This way both the computer and the phone are connecting through the same wifi node. (And if I don’t see full wifi bars on the phone, I just restart the wifi on the phone to get it to connect to the closest wifi node.) This has worked reliably for 6 months. The first time I was unable to connect was when I had Zwift do the most recent update, and since then I’ve only gotten the companion app to connect at most two times, but many, many times of not connecting.

Help! I need that mini-map for racing tactics.

Also companion app is fully up to date.

That sound like a network issue.

Restarting the router. Make sure the phone does not go to mobile data.

If that does not help, then it might bet network IP settings.

I’ve seen some other reports of this happening when users have a mesh network.

What if you try this with the Macbook too, so it re-connects to the same node?

1 Like

Yeah, I’m going to try restarting everything at the same time tonight, but it really was never happening before the update and immediately after the update has happened something like 90% of the time.

Hi @John_Bowers,

I’m Steven with Zwift support, and I’m sorry to hear that you’ve run into trouble with the ZC app not connecting. I get how that can be frustrating, especially considering you’ve tried a lot of the basic troubleshooting, and it sounds like this was less of an issue before the update.

While I haven’t personally seen anything trending yet with regards to ZC app connection issues since the last update, as some of the others mentioned here it sounds like a network issue as far as I can see. I’d mentioned you’ve tried the basic stuff, but there are some more advanced issue troubleshooting steps listed in our related article. The pertinent information is about midway down the page of the article, so I’d suggest trying that.

I’ll parrot what others have mentioned as well in that I’ve seen a number of reports historically of issues where the ZC app won’t connect on the mesh networks. So, that can be tricky.

Do your best to work through those suggestions from the article, and if issues persist I’d suggest contacting our support team directly here, and we’re happy to work with you.


1 Like

Ok, I now believe this is a mesh network related problem and a coincidence it occurred just when I updated. I loaded my Linksys app and found that for some reason the laptop was connected to one of the network nodes that was further away from the Wattage Cottage, and as a result my phone and laptop were connected to different nodes, since my phone had connected to the node with the strongest signal. Turning the wireless off and on on the laptop simply reconnected to the further node for some reason. I restarted the computer and then it automatically connected to the closer network node and I verified that both the phone and laptop were connected through the same node. Then I fired up Zwift and the ZC and immediately the mini-map appeared. I’ll test over the next week, but I’m now pretty convinced the problem is when the laptop and phone connect to different nodes.

But this doesn’t seem like it should be a problem for Zwift. The mesh network is supposed to be pretty transparent to the application layer, and network discoverability is working perfectly fine for other devices on the network, like my printer.

I would be happy to help debug if there’s some network scanning that would help diagnose the issue.

Yes, I’ve been having this issue too since yesterday. The way I found to fix it is re-downloading the Zwift Companion app and re-connecting to the Wi-Fi.

It’s supposed to be transparent, but you’ve demonstrated that it’s not transparent on your own mesh network.

Zwift only cares that the Companion app device can talk with the Zwift app device over your local network. Something stopped that on your own network, and as you say it may well be the different nodes thing.

I spoke too soon. The problem is ongoing even when both the phone and the laptop are on the same node. And I can see in the Zwift logs that they are trying to connect to each other. I am in Zwift right now and the companion app is failing to connect, but Zwift knows the IP address of my phone. Here’s a relevant entry from the log on my laptop:

[21:11:44] NETCLIENT:[INFO] Auxiliary Controller attempting to connect to phone at: is the correct IP address, which means the Zwift client is identifying the existence of the phone on the network, but is failing to trigger the proper response. A little bit later in the log I get:

[21:11:44] Received details about meetup 2687920
[21:11:45] FPS 20.35, 86479, 11794, 204202
[21:11:49] NETCLIENT:[INFO] Auxiliary Controller failed to connect to socket: ‘Operation aborted.’ (89)
[21:11:52] NETCLIENT:[INFO] UDP metrics {StC Rx: 500, Rx error: 0, CtS Tx: 60, Tx error: 0}
[21:11:53] FPS 20.22, 86479, 11794, 204202
[21:11:54] NETCLIENT:[INFO] Sending telemetry…

Also this problem most definitely started the day I updated to the current latest Zwift client. I have been able to use the mini map in the ZC only twice and I’ve ridden almost every day, so this is at least 5 days or so of failures since the update. Restarting both Zwift and the companion app fails to fix the issue.

It’s a coincidence that this started with you doing a Zwift update. It’s a routing issue on your local network, I’m afraid to say.