BT not working with Zwift since Windows 10 update

Hello all,

I wonder if someone can help me? My laptop updated to the latest Windows 10 release (sac 1909 I think) and also the Zwift app updated. Since then (yesterday) my built in Bluetooth has simply stopped working with Zwift. It always worked perfectly before the updates, now it simply will not connect to my turbo or heart rate monitor with Bluetooth.

I have an ANT+ dongle - so I tried that and it connects fine. HOWEVER, my laptop doesn’t work with dongles, it turns the port off claiming it’s trying to “sleep and charge”. Which is twoddle as I’ve turned off sleep and charge in the settings and the BIOS. I even use the dongle from a powered USB hub which is simultaneously charging the turbo.

So, I guess, I need to know either; how to get Win10 1909/Zwift to work with built in Bluetooth or how to stop my usb ports being turned off by a pants Toshiba software.

Cheers,
Glen.

Try reinstalling the runtime package from this link - https://www.techpowerup.com/download/visual-c-redistributable-runtime-package-all-in-one/

1 Like

Thank you very much. I ran that batch file and it’s helped the laptop - it’s much faster now (or should I say, it was running much slower before the update and now it’s back to it’s normal speed).

However, there’s no improvement on the Bluetooth connecting with Zwift front.

And “sleep and charge is ready” icon still pops and knocks out the usb ports.

Cheers,
Glen.

I can confirm that this is a zwift issue, not a windows issue, as I can transfer files etc via bluetooth and connect to new devices etc. The only Bluetooth thing I can’t do is connect to the turbo via zwift with Bluetooth (since the updates).

Edit:
I googled “windows 10 realtek bluetooth problem” and the second item is a link to support.microsoft. I followed the steps and it seems to have fixed the problem. Strangely I did not get the warnings that microsoft suggest I would see. And also realtek list that as a 4.2 driver, not a 4.0 driver. However, replaced the driver and it’s now working with zwift. :slight_smile:

“Microsoft has identified compatibility issues with some driver versions for Bluetooth radios made by Realtek. You will need to update to driver version 1.5.1012 or later to remove this safeguard hold. Any earlier version of the driver is affected by this issue.”
The driver from the link that worked was 1.5.1012.3, I had 1.5.1010.