Bowflex C6 bike not connecting to Zwift

I am not sure how many people here ride the C6 bike, but today I was setting up to ride it and it would not connect to Zwift. I can connect through bluetooth to the Wahoo app and to Bowflex’s own app but not to Zwift. If anyone else is having this issue or has had this issue any help would be great appreciated!

Make sure you disconnect the C6 from any device or app (including the device you are running Zwift on) before you open Zwift. So, it it is an iPhone go to Settings>Bluetooth Select the C6 and forget Forget this Device. Bluetooth only allows one connection to any device or app at a time.

1 Like

I tried that, and it was not on there to forget. It still doesn’t show up with I try to run Zwift through my PC.

@Austyn_Hughes

Are there any other apps that might be stealing the Bluetooth signal? You mentioned the Wahoo and Bowflex apps. Please make certain those are forced close.

If you have multiple devices to run the Zwift app, please also make sure you aren’t logged in concurrently. Always exit your test sessions by trashing them, rather than just leaving them running in the background on your device.

1 Like

The only thing on bluetooth (where my bike is, is my bike). Just last week, it would connect automatically and now it doesn’t even recognize anything.

I have closed the PC version of Zwift off, and restart it to test it again.

(Of course I have spoken with Bowflex and they blame it on Zwift.)

@Austyn_Hughes
I took at look at your session logs on our server going back a few weeks.

Please provide a little more context of when you connect via ANT+? Some days, there’s an ANT+ dongle attached to your Windows computer, and other times, there’s no sign of it on our server, as if you physically remove it from the laptop. Is that what’s happening on your end?

On June 26, you were on game version 1.0.53028 and paired via Bluetooth to something identified as “IC Bike” on the cadence, power and controllable signals. I trust that’s the Bowflex? That day, 21.1 miles were recorded.

June 27, game version was updated to 1.0.53029. Same IC Bike paired via Bluetooth for a 27.2 mile ride. By this, we can assume that the game version update had no negative effect.

June 29, an ANT+ USB stick is paired. I see a Tickr HR monitor paired via BLE. Not seeing any “IC Bike” recorded, yet somehow 32.1 miles were ridden. Would you look at your activity history on my.zwift.com and tell me about this session? Did this one work as you expected?

I have two (2) different bikes that I use at two (2) different locations. The data stated above was acquired using a “dumb” trainer at my apartment using Ant+ to connect to a Wahoo speed sensor, Wahoo cadence denser, and a Wahoo TickR. So all those rides where used using it, one day, I forgot to connect the Ant+ adapter to my PC so that is why one of the rides didn’t use the Ant+ adapter.

The rides on 6/24, 6/26 and 6/27 were all on the C6 Bowflex bike. Which doesn’t have Ant+ compatibility (which is sorely needed).

By the way, I am leaning more towards this being a Bowflex issue and not a Zwift issue (I am not sure if my sarcasm in my last post was missed). I have attached my Assioma pedals to it tonight so I should be good to go tomorrow. Thank you for your help so far though, Zwift has some of the best customer support out there!

@Austyn_Hughes
Should you contact Bowflex support, please ask if there’s a way you can update the firmware on their bike. It’s possible that a newer version will fix pairing issues.