Bluetooth stopped working


(Michael Ziock) #1

Today (June 1) the Zwift PC app took an update and since then I cannot get Bluetooth to connect.  While the PC shows it is getting signal from the phone and both HRM and power/cadence show connected in the iPhone, the iPhone app shows the “red” Bluetooth icon and the message:  “There are no connections.  Use the PAIRED DEVICES screen in the game to connect to your gear.”  I have tried with two different PCs and while both worked before the update, they are experiencing the same problem after the update.


(Michael Ziock) #2

To provide some additional troubleshooting information:  I did use Search multiple times on Power and it would not find it.  I was able to hit search on the HRM and have it find it without problem.  Interestingly, I used search on the Cadence sensor and it found that as well but this caused the iPhone app to crash.  If I unpaired Cadence through the Zwift app the iPhone app would work.  As soon as I searched Cadence and it found it and I connected, the phone app would crash.  I could never have it find Power.

 


(Eric C. (Zwift HQ)) #3

Hi Michael,

Is your trainer/power meter paired TO the phone itself at all?


(Michael Ziock) #4

Both the HRM and Power meter (Kinetic InRide) show on the phone.  I have been using it without issue for a couple of months since joining Zwift without problems.  What I notice is that the computer app shows it is happy with  the BT signal it is getting from the phone.  What has changed is that unless I press “search” it doesn’t find the HRM or InRide (in the past the HRM would connect automatically and one light press of the bike pedal caused Power and Cadence to connect immediately).  As of today I can only search HRM and Cadence and Power never shows up (as previously mentioned, when Cadence connects the iPhone crashes).  Some other troubleshooting I have tried:  (1) rebooted the PC multiple times, (2) restarted the iPhone, (3) disabled and re-enabled BT and (4) confirmed the HRM and Power/Cadence work without issue when using the Kinetic app. 

I am making an assumption that it is tied to the latest PC update as it has been working flawlessly until today and the failure scenario is odd in that the PC is happily showing the BT connection but is not seeing the devices as it used to.  Thanks for any help as it was MIND NUMBING to ride without Zwift today. :slight_smile:


(Eric C. (Zwift HQ)) #5

Hi Michael,

Try un-pairing the InRide from your phone, closing (not minimizing) the Kinetic App, and then running the Zwift Mobile Link. I am kind of surprised that it ever worked with Zwift because pairing your InRide with the phone tends to block the signal from being passed on to Zwift.


(Michael Ziock) #6

I wasn’t running the Kinetic app and Zwift app simultaneously.  I only wanted to call out that the HRM and InRide worked without issue when I used the Kinetic app.  The issue occurs when Zwift is the only app I am using.  I will try un-pairing and re-pairing the InRide and HRM although I presumed turning off BT and then restarting and having the devices reconnect in the iPhone accomplished the same thing.  I will have to try it out later today and will report back on success/failure.

If un-paring and re-pairing doesn’t do the trick anything else you can suggest?  Is there any chance it related to the Zwift PC app update?  Is there anyway to revert to a previous build of the PC app to see if it resolves the issue?


(Eric C. (Zwift HQ)) #7

If it doesn’t work then it might be an issue with the latest update. We are trying to confirm in-house.


(Matt Cumming) #8

Exact same issue but on Mac.

Mine finds the cadence sensor (on Zwift) but only when I search for it - prior to the update it used to find it straight away.  When I connect to it my Zwift mobile app then crashes and continues to do so until I reset Zwift on the Mac.

The power meter does not detect at all despite changing batteries, re-pairing etc.  The sensors work beautifully on the Kinetic app but nothing on Zwift.

This all started after the download today - is there a way of rolling it back? I’m desperate to start training again after 3 months off!


(peter smith) #9

I have had the same issue with my in-ride app today after an hour of trying to get it to work I gave up and just used the Kinetic app instead 


(peter smith) #10

My issue was with a Mac and iPhone 


(Matt Cumming) #11

I’ve just spoken to support on live chat and it’s a known issue (I’m guessing they’ve recreated it).  

Said there is a fix on the way in the next 24 hours or so…


(Eric C. (Zwift HQ)) #12

Hopefully quite soon.


(Jerry Bob) #13

i haven’t been able to connect via bluetooth since the 5/4 update. not hopeful as opened a ticket and answered all the questions, sent log file etc.  have tried everything under the moon. the problem is at zwift as there was no problem before 5/4 update … just frustrating not to have this option…ANT+ working fine so its a small issue but would be good have it sorted. 


(Matt Cumming) #14

Without Bluetooth connection I cannot use Zwift as my trainer needs it to transmit the power readings. Prior to the last update it worked perfectly!


(Todd Drake) #15

I have the same issue as the OP, I spent about 30 min via live chat with Eric C - Hi Eric - I noticed the same app crashing issue as soon as I searched for the cadence sensor (Kinetic InRide) but nothing when I search for the PM - The phone app is not showing any data from the sensors either.

 


(Jon Mayfield) #16

UPDATE:

We found one version 2 inRide pod and I’ve managed to fix the code so that it works now.  I’ll try and have an update published within the next 24 hours for this issue.   All the stores around here still just sell the old version (which continues to work fine) so it was fun tracking one down.


So it turns out there are multiple versions of the inRide sensor (and they both look the same), and the one I’ve got on my Kinetic here still works fine.

One module was made by Wahoo, and one was made by another manufacturer.  It appears the one we have lots of is the wahoo one, and it appears to work.   The one from the other manufacturer does seem like it stopped working and as soon as I get my hands on one (today hopefully) I can see what is going on with it.

Having 2 devices look the same but not act the same didn’t make testing the inride easy.

 


(Brad Collis) #17

Just want to add that my bluetooth connection between iphone and Zwift has stopped as of two days ago. Having to abandon Zwift and go back to another program. Hope this is resolved soon


(Matt Cumming) #18

Just read the official update from Jon Mayfield. Appreciate the difficulties in the two different devices, but it was working fine prior to the programme update. Is there any progress on the fix as at the moment zwift is clearly not working for quite a few of us.


(Jon Mayfield) #19

We found one version 2 inRide pod and I’ve managed to fix the code so that it works now.  I’ll try and have an update published within the next 24 hours for this issue.   All the stores around here still just sell the old version (which continues to work fine) so it was fun tracking one down.


(Brad Collis) #20

Good news … yes, Kinetic are offering a replacement option for its version 1 pod so most InRide users will probably soon be on V2 which is said to have a number of advances over V1.