Bluetooth music volume lowered when chat messages pop up


(Kit Mitchell) #1

This may well be more of an issue related to my phone/settings than anything at Zwift’s end but…

Like many people, I enjoy listening to music while I Zwift. I use a basic surround sound system with a Bluetooth connection to my phone (where the music is stored). 

If I have the Zwift phone app running, the music decreases greatly in volume every time a chat message pops up on the screen. This has led to me stopping using the Zwift phone app. 

Is there any way to stop the ‘temporary decrease in volume’ and let me use the Zwift phone app again without interruptions?

I don’t want to switch chat off altogether - it is a social experience after all - but the way it lowers the volume really irks me. 

In case it’s relevant, I’m using an Android phone and running Zwift on Apple TV. 

Thanks in advance to anyone who can and does help. 


(Gerrie Delport) #2

Go to your android notifications and turn off “Allow interruptions” 


(Kit Mitchell) #3

Super! Thanks Gerrie. Much appreciated. I’m something of a Luddite when it comes to phones.

It didn’t say ‘Allow interruptions’ but rather said ‘Show silently’. I assume that’s the same option only the other way round so moved the virtual sliding switch to ‘on’. 

Haven’t tried it out yet but presumably that’ll do the job. I will look forward to being able to use the app without aural interruption. 

Thanks again.


(Kit Mitchell) #4

Dagnabbit! Annoyingly, that didn’t work. Despite setting the Zwift app to ‘Show silently’ it still lowers the music volume every time someone writes a message. 

I should point I’d like to continue to get notifications from the Zwift app - I just don’t want it decreasing the volume of music I’m listening to. Perhaps there’s no viable solution?

Maybe putting my phone in a ‘do not disturb’ type mode would get round it? That written, I don’t want to miss calls.

Unfortunately ‘using a 3.5mm jack lead’ isn’t a viable option with the setup I have. 

If anyone has any ideas to get round this, please let me know. Thanks.


(Gerrie Delport) #5

O no, there must be an option to turn the notifications off. :frowning:

So here are the steps that I used.

 go to :  settings - Apps & notifications - Notifications - App notifications - scroll to “Mobile Link” - turn off “Allow interruptions” or turn every thing off.

 

I will search to see if I can find other settings.

 

 

 


(Kit Mitchell) #6

Thanks once again Gerrie. 

I fear that’s what I’ll end up having to do - switching off all the Zwift notifications to stop it from fiddling about with the volume. 

It’s a bit of a pain to lose any notifications but it’s better than not being able to use the app at all.  

From the little I’ve read about this, I think it’s a reasonably common complaint people have with Android phones and goes back years. I don’t think it’s something Zwift is in any way responsible for.


(Stephen Higgins) #7

I’d really like an answer for this. It’s really annoying on big group rides, I love the chat but hate the ‘woop’ noise interrupting my music every ten seconds

 

mine even seems to pause the music for a split second before and after, meaning the beat changes.

 

I can’t seem to find any settings that change it


(Kit Mitchell) #8

For the sake of a minor update - I tried switching notifications off altogether for Zwift’s app but it still lowers the volume every time someone chats. 

It makes playing music and using the Zwift app at the same time far too annoying to consider. The music wins that battle and thus I can’t use the Zwift app. 


(Stephen Higgins) #9

I’d like to try using the app as a Bluetooth bridge (although I haven’t figured out how yet) but it’s going to be quite annoying with the chat interrupting my music


(Kit Mitchell) #10

It took me ages to discover how the Zwift app works as a Bluetooth bridge. As luck would have it, I clumsily stumbled across it yesterday while fiddling about with the settings, trying to stop it lowering the volume.

  1. When you’re in the pairing screen on Zwift, open the app on your phone. Firstly, make sure your Bluetooth is on (pretty obvious that bit I guess).

  2. Once the Zwift app changes to that ‘Yep, I’m aware you’re using Zwift now’ dark blue background, you should see a wee Bluetooth logo up beside the Notifications flag or whatever icon is at the top-right of the screen.

  3. Tap the Bluetooth icon.

  4. Now return to your Apple TV (which I assume you have and is the limiting factor in this scenario). When you attempt to add more than two* devices, it should now let you pair the extra one(s).

  5. Enjoy your virtual cycle.

At least that’s how it worked for me (twice so far). That’s using an Android device and our AppleTV box. 

Please let me know if that works for you. I hope it does. Had I been aware of it previously, I wouldn’t have shelled out about eighty quid on a 4iiii Viiiiva.  

In other news, today I caught on to a bit of an obvious workaround for the volume decrease. I simply used my phone for music and a cheap tablet for the Zwift app. As it was running on two separate devices the pop-up chat messages didn’t bother the music. 

It’s far from a perfect solution but at least it lets me listen to music, run the app and not have any volume reduction annoyance. I’m really fairly/very stupid for not thinking of it initially - duh!

* NB: Yeah, I know AppleTV connects to three Bluetooth devices but I kinda need to use the remote control so it has to be one.


(Stephen Higgins) #11

Thanks Kit, there’s some useful information in there. I don’t currently have an Apple TV but I’m thinking about getting one.

I’ll have a play around next time I get the chance


(Kit Mitchell) #12

You’re very welcome Stephen. 

Sorry, I presumptuously assumed your needing to use the app as a Bluetooth bridge was because of having an AppleTV. That’s certainly why I now use it.

Presumably other systems have similarly limited connectivity.

On the subject of running Zwift on an AppleTV box - it’s great other than some annoyances with custom workouts and not being able to shut the annoying music up. I find it so much handier than using a PC was. 


(Stephen Higgins) #13

Genius! My problems are solved! I used your idea of multi devices.

I have an old smart phone that works OK except the camera is broken.

I followed your instructions to create a Bluetooth bridge, and then Zwift crashed, but on a second attempt I got it to work!

So now I’m using my new phone for the music and the old phone as a Bluetooth bridge running the mobile link, it works fantastically with no detectable wattage dropouts that I was getting with ant+ and no interruptions to the music.

It would have been one of my best rides ever on Zwift had my new phone not jumped off the shelf about 25 minutes in as I was cresting box hill and smashed it’s screen on my garage floor :frowning:

Thanks for the help. The improvement is so marked I’m thinking of putting a post up here just telling people to get off ant+ for their power readings and use Bluetooth


(Kit Mitchell) #14

That’s splendid Stephen , other than the ‘health status’ of your new phone. I’m pleased to see we’re able to work around ‘annoying volume lowering’.  

I keep knocking phones and remote controls off stools and plinths of all manner when Zwifting. Thankfully I’ve got away with it up to now. I need to invest in a load of that high density foam tiling. Probably about ten square miles of it, with me right in the middle, would stop me breaking (some) stuff. 


(Stephen Higgins) #15

I’m a little upset about it, my old phone is nearly 5 years old now and still looks mint, the one in between was still in great condition when it had an internal hardware / software fault, and then I went and bought an honor 9, which was great but the back of it is so low friction it turns out you can leave it on a flat surface and it will still slide off it.


(Kit Mitchell) #16

I hadn’t heard of an Honor 9 before (I know nothing about phones). Looking at the price, I’m not surprised you’re a little upset. 

Had it been me, anyone around could have seen a grown man cry.