Bluetooth connection after iOS update


Since updating my IPhone to the latest software Zwift will no longer pick up my Bluetooth wahoo cadence and speed sensors.

Both sensors still function on the wahoo iphone app, show up on my Bluetooth settings and connect to my laptop when using Zwift, just not on my phone.

Is this a known error and is there a solution for this? I’ve tried reinstalling Zwift and forgetting the Bluetooth connection before reconnecting everyone as trouble shooting but still no luck.

Any help is appreciated.


Welcome to the Forum, Mark!

There is a known issue with the iOS 13 and tvOS 13 updates where privacy settings go reset. You may need to go into your devices bluetooth privacy settings and allow zwift to properly access your bluetooth.

I wouldn’t call it “a known issue” making it sound like a bug. Apple increased privacy and security in iOS 13 and tvOS13. There are new relevant settings.

Settings > Privacy > Bluetooth: Enable/Allow Zwift access

Force quit Zwift. Restart Zwift. All should be good to go!


Hi, I have two Tacx flux smart at home. My wife and I are using iPhone with IOS13. I usualy train with my wife. Today, we had a connecting issue. Both of my Tacx have benne reconnized by my Zwift app. And my wife zwift app did not see anyone of the tacx. I tried to close my app. At this moment, my wife app reconnized both tacx and I lost the connection at the reopening of my zwift app. Have you heard other people with thi issue?

The usual cause for the bluetooth issue you’ve described is interference. We’ve written a guide describing the most common interference sources​ in the article “BLE vs ANT+ Interference Troubleshooting Tips​” which should help you eliminate them.

You may need to move the devices further apart from each other.

Let us know how it goes!