iPad Pro no Bluetooth sensors after update

I can see all my sensors though iOS settings and wahoo app, but not being recognized by the Zwift app after yesterday’s update (21 Jan). Completed all the troubleshooting I can find online, restarted everything and still no luck. Deleted app and reinstalled. Any thoughts appreciated. Trying to connect Kickr and Wahoo cadence and hr monitors - all worked yesterday before update. Tom

Same issue here using iPad Pro with a Kinetic trainer. Things I’ve tried that haven’t worked:

  • Confirmed Bluetooth connectivity with the native Kinetic app still works
  • Restarted iPad Pro
  • Deleted app on iPad Pro and reinstalled
  • Changed battery in trainer
  • Installed Zwift on my iPhone 12 Pro Max, same issue with it

Since the same bluetooth issue is affecting both my iPad and my iPhone, it appears that an iOS bug has been introduced.

1 Like

There’s another thread with discussing this issue. I’ve had the exact same experience and tried most of the fixes that Frank tried for my KICKR (no battery to change in my setup).

Oddly, my wife has the exact same KICKR model and iPad that I do and her setup worked this morning. She did say that it took several attempts to get Zwift to pair and function.

So someone at Zwift HQ has introduced a bug into the Zwift app that’s affecting iOS users and hence, Bluetooth connections.

not just ipad pro, Ipad air 7, 4, and 2 I think are not working.

1 Like

iPad Pro, Tacx Flux S Smart same issue.
iPhone XS work well after the Update so not a General iOS issue :thinking:

That’s interesting that the iPhone XS is working. I’m almost tempted to download Zwift on my iPhone 12 and see if it works. But I’ve wasted enough time on trying to get Zwift to connect today, so I’ll maybe try the iPhone tomorrow.

Same issue with older iPad. Newer one works. But can’t get my wahoo heart rate monitor to work now.

I tried 2 more devices today and my old iPad mini 4 and iPhone 11 are working. Only my iPad Pro won’t work After this Update. I tried also a re installation and a network settings reset without any result…

Same issues on iPad Pro 9.7 with Tacx Neo. Even it detected on Tacx app. And it also detected on iPhone 12 mini.